Collegamento wi-fi funzionante solo dopo reboot del Notebook

La rete, Internet, configurazione di Servizi e tutto ciò che permette la comunicazione tra macchine

Collegamento wi-fi funzionante solo dopo reboot del Notebook

Messaggioda seb » 14/12/2018, 13:31

Salve a tutti, questo è il mio primo post nel forum, quindi vi prego di perdonarmi se non vi fornisco tutte le informazioni necessarie o se ho sbagliato l'impostazione del titolo, categoria ecc... .
Scrivo qua perchè ho un problema che proprio non riesco a risolvere con network manager. Premetto che provengo da ubuntu ed è solo una settimana che ho Debian quindi ancora non mi sono chiare completamente le dinamiche.

Ogni volta che accendo il Notebook questo si collega automaticamente alla rete. Se non vi sono reti disponibili, appena ne trovo una e la seleziono, questa si collega e tutto va bene. Il problema nasce nel momento in cui voglio cambiare rete (o se il PC va in sospensione). A questo punto non riesco più a connettermi ad alcuna rete, nemmeno a quella che precedentemente funzionava. Il log di network-manager è il seguente:

AL RIAVVIO:



Codice: Seleziona tutto
[...]
dic 14 12:16:55 debian-seb NetworkManager[676]: <info>  [1544786215.7875] dhcp4 (wlan0): state changed unknown -> bound
dic 14 12:16:55 debian-seb NetworkManager[676]: <info>  [1544786215.7891] device (wlan0): state change: ip-config -> ip-c
dic 14 12:16:55 debian-seb NetworkManager[676]: <info>  [1544786215.7900] device (wlan0): state change: ip-check -> secon
dic 14 12:16:55 debian-seb NetworkManager[676]: <info>  [1544786215.7903] device (wlan0): state change: secondaries -> ac
dic 14 12:16:55 debian-seb NetworkManager[676]: <info>  [1544786215.7908] manager: NetworkManager state is now CONNECTED_
dic 14 12:16:56 debian-seb dhclient[1608]: bound to 192.168.1.59 -- renewal in 36090 seconds.
dic 14 12:16:56 debian-seb NetworkManager[676]: <info>  [1544786216.0978] manager: NetworkManager state is now CONNECTED_




TENTATIVO CAMBIO DI RETE E/O RICONNESSIONE DOPO LA SOSPENSIONE:



Codice: Seleziona tutto
[...]
dic 14 13:02:18 debian-seb NetworkManager[5027]: <info>  [1544788938.3185] Config: added 'ssid' value 'Perg52'
dic 14 13:02:18 debian-seb NetworkManager[5027]: <info>  [1544788938.3185] Config: added 'scan_ssid' value '1'
dic 14 13:02:18 debian-seb NetworkManager[5027]: <info>  [1544788938.3186] Config: added 'bgscan' value 'simple:30:-80:86400'
dic 14 13:02:18 debian-seb NetworkManager[5027]: <info>  [1544788938.3186] Config: added 'key_mgmt' value 'WPA-PSK'
dic 14 13:02:18 debian-seb NetworkManager[5027]: <info>  [1544788938.3187] Config: added 'auth_alg' value 'OPEN'
dic 14 13:02:18 debian-seb NetworkManager[5027]: <info>  [1544788938.3187] Config: added 'psk' value '<hidden>'
dic 14 13:02:28 debian-seb NetworkManager[5027]: <info>  [1544788948.9616] device (wlan0): supplicant interface state: disconnected -> scanning
dic 14 13:02:31 debian-seb NetworkManager[5027]: <info>  [1544788951.2820] device (wlan0): supplicant interface state: scanning -> disconnected
dic 14 13:02:41 debian-seb NetworkManager[5027]: <info>  [1544788961.7665] device (wlan0): supplicant interface state: disconnected -> scanning
dic 14 13:02:43 debian-seb NetworkManager[5027]: <warn>  [1544788963.8724] device (wlan0): Activation: (wifi) association took too long, failing activation
dic 14 13:02:43 debian-seb NetworkManager[5027]: <info>  [1544788963.8725] device (wlan0): state change: config -> failed (reason 'ssid-not-found', sys-iface-state: 'managed')
dic 14 13:02:43 debian-seb NetworkManager[5027]: <warn>  [1544788963.8754] device (wlan0): Activation: failed for connection 'Perg52'
dic 14 13:02:44 debian-seb NetworkManager[5027]: <info>  [1544788964.4896] device (wlan0): set-hw-addr: set MAC address to CA:75:C2:D9:70:67 (scanning)
dic 14 13:02:44 debian-seb NetworkManager[5027]: <info>  [1544788964.4944] device (wlan0): supplicant interface state: scanning -> disconnected
dic 14 13:02:44 debian-seb NetworkManager[5027]: <info>  [1544788964.7108] device (wlan0): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed')




Le ho provate di tutte ma proprio non riesco a risolvere il problema. Ho aggiornato network manager, disintallato e reinstallato, aggiornato al kernel 4.17 eppure nulla, il problema è sempre il soltio, La cosa che non capisco è che il driver che utilizzo (scheda di rete realteck, driver rtl8821ce) è lo stesso che avevo con ubuntu, e li funzionava tutto alla grande. Sapete come aiutarmi? Vi ringrazio moltissimo in anticipo, e buona giornata a tutti.
seb
Newbie
Newbie
 
Messaggi: 2
Iscritto il: 14/12/2018, 13:14

Re: Collegamento wi-fi funzionante solo dopo reboot del Note

Messaggioda s3v » 21/12/2018, 21:49

Puoi gentilmente allegare il file compresso creato tramite questo script?
I driver li hai prelevati dai repository di Debian?

Benvenuto nel forum.
Avatar utente
s3v
Global Moderator
Global Moderator
 
Messaggi: 5619
Iscritto il: 31/12/2008, 11:54


Torna a Network

Chi c’è in linea

Visitano il forum: Nessuno e 6 ospiti