Forum Debianizzati

Condividi contenuti
Aggiornato: 1 min 30 sec fa

Re: Problema aggiornamento - /usr/bin/dpkg returned an error

Dom, 10/06/2018 - 18:46
Cioè mi vuole eliminare tutti ikernel che ho in /boot?no, semplicemente ti dice i pacchetti che non necessitano al sistema e che possono essere eliminati, dato che tu gli hai detto di fare l'autoremove

autoremove

# apt-get autoremove

Rimuove i pacchetti installati automaticamente e che non sono più necessari in quanto dipendenze solo di altri pacchetti rimossi.
Il messaggio con cui apt ci avverte della loro presenza è:

Il seguente pacchetto è stato installato automaticamente e non è più richiesto:
nomepacchetto1 nomepacchetto2 ...
Usare "apt-get autoremove" per rimuoverlo.

La lista dei pacchetti installati con status di "autoremove" può essere visualizzata con:

$ aptitude '~i ~g'

Questo comando può essere combinato con l'opzione "--purge" (vedere il paragrafo "Opzioni").

Specificando questo comando con il nome di uno o più pacchetti, si otterrà la loro rimozione e, contemporaneamente, la rimozione di tutti i pacchetti non più necessari. Vedere anche l'opzione "--auto-remove" e la direttiva "APT::Get::AutomaticRemove". Esempio:

# apt-get autoremove pacchetto1, pacchetto2 ... pacchettoN

Categorie: Forum Debianizzati

Re: Problema aggiornamento - /usr/bin/dpkg returned an error

Dom, 10/06/2018 - 12:26
non utilizzare l'opzione autoremove ma usa il comando base
# apt-get remove pacchetto1 pacchetto2 ... pacchettoN
oppure
# apt-get purge pacchetto1 pacchetto2 ... pacchettoN

in ogni caso guarda la guida http://guide.debianizzati.org/index.php/Apt-get
Categorie: Forum Debianizzati

[Risolto] Problema aggiornamento - /usr/bin/dpkg error

Dom, 10/06/2018 - 10:30
Ciao a tutti,
questa mattina stavo aggiornando la mia Debian Buster e dopo aver dato sudo aptitude safe-upgrade ho ricevuto questo output:
update-initramfs: Generating /boot/initrd.img-4.16.0-2-amd64

gzip: stdout: No space left on device
E: mkinitramfs failure cpio 141 gzip 1
update-initramfs: failed for /boot/initrd.img-4.16.0-2-amd64 with 1.
dpkg: errore nell'elaborare il pacchetto initramfs-tools (--configure):
 installed initramfs-tools package post-installation script subprocess returned error exit status 1
Elaborazione dei trigger per libc-bin (2.27-3)...
Si sono verificati degli errori nell'elaborazione:
 initramfs-tools
E: Sub-process /usr/bin/dpkg returned an error code (1)
Configurazione di initramfs-tools (0.130)...
update-initramfs: deferring update (trigger activated)
Elaborazione dei trigger per initramfs-tools (0.130)...
update-initramfs: Generating /boot/initrd.img-4.16.0-2-amd64

gzip: stdout: No space left on device
cpio: errore di scrittura: Pipe interrotta
E: mkinitramfs failure cpio 2 gzip 1
update-initramfs: failed for /boot/initrd.img-4.16.0-2-amd64 with 1.
dpkg: errore nell'elaborare il pacchetto initramfs-tools (--configure):
 installed initramfs-tools package post-installation script subprocess returned error exit status 1
Si sono verificati degli errori nell'elaborazione:
 initramfs-tools


Mi sembra di capire che ho la partizione /boot piena (usando LVM con full disk encryption ho la partizione di boot separata.

Devo quindi eliminare una qualche linux-image vecchia. Dando il comando aptitude search ~ilinux-image vedo che ho:

i A linux-image-4.14.0-3-amd64                   - Linux 4.14 for 64-bit PCs                             
i A linux-image-4.15.0-2-amd64                   - Linux 4.15 for 64-bit PCs                             
i A linux-image-4.15.0-3-amd64                   - Linux 4.15 for 64-bit PCs                             
i A linux-image-4.16.0-1-amd64                   - Linux 4.16 for 64-bit PCs                             
i A linux-image-4.16.0-2-amd64                   - Linux 4.16 for 64-bit PCs                             
i   linux-image-4.9.0-3-amd64                    - Linux 4.9 for 64-bit PCs                               
i A linux-image-4.9.0-5-amd64                    - Linux 4.9 for 64-bit PCs                               
i   linux-image-amd64                            - Linux per PC a 64 bit (metapacchetto)   


Provo ad eliminare l'immagine 4.9.0-3-amd64 (visto che non è una dipendenza), ma cmq output ho:
sudo apt-get autoremove linux-image-4.9.0-3-amd64
[sudo] password di leo:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti saranno RIMOSSI:
  linux-image-4.14.0-3-amd64 linux-image-4.15.0-2-amd64 linux-image-4.15.0-3-amd64
  linux-image-4.9.0-3-amd64 linux-image-4.9.0-5-amd64
0 aggiornati, 0 installati, 5 da rimuovere e 5 non aggiornati.
1 non completamente installati o rimossi.
Dopo quest'operazione, verranno liberati 1'141 MB di spazio su disco.
Continuare? [S/n]

Cioè mi vuole eliminare tutti ikernel che ho in /boot? Prima di fare qualche cavolata ho risposto di "no".

Cosa mi consigliate di fare?

Ciao ciao leo:)
Categorie: Forum Debianizzati

Re: mariadb tabella che crasha

Sab, 09/06/2018 - 12:28
ho fatto un truncate delle tabelle
TRUNCATE `data_bin`;
TRUNCATE `index_data`;
TRUNCATE `metrics`;

e adesso pare a posto
amen
Categorie: Forum Debianizzati

Re: apt-get autoremove

Ven, 08/06/2018 - 09:54
Aggiunge dei dettagli in più.
Ho re-installato apache2 tramite 'apt-get install apache2'.
Mi sarei aspettato che i flag delle dipendenze si sarebbero sistemati, invece vedo:

aptitude search apache | grep -v ^p | grep -v ^v
iB  apache2                         - Apache HTTP Server                       
id  apache2-bin                     - Apache HTTP Server (modules and other bina
id  apache2-data                    - Apache HTTP Server (common files)         
id  apache2-utils                   - Apache HTTP Server (utility programs for w


Aprendo aptitude condiglia di rimuovere un pacchetto (apache2).
Queste sono le azioni che consiglia:

Premendo 'g' per rimuovere apache2 (da aptitude), rimuove anche le dipendeze

se invece eseguo aptitude da riga di comando, non rimuove le dipendeze "guaste".

aptitude remove apache2
I seguenti pacchetti saranno RIMOSSI:               
  apache2
0 pacchetti aggiornati, 0 installati, 1 da rimuovere e 0 non aggiornati.
È necessario prelevare 0 B di archivi. Dopo l'estrazione, verranno liberati 502 kB.
(Lettura del database... 95975 file e directory attualmente installati.)
Rimozione di apache2 (2.4.18-2ubuntu3.8)...
Elaborazione dei trigger per man-db (2.7.5-1)...
Elaborazione dei trigger per ufw (0.35-0ubuntu2)...
Categorie: Forum Debianizzati

[RISOLTO] mariadb tabella che crasha

Ven, 08/06/2018 - 08:52
ho una VM con 2 vcpu, 3gb ram, mariadb 10.0.32, debian 8.10, centreon (una specie di nagios)
in /var/log/syslog ho:
Jun 8 08:30:06 cloro mysqld: 180608 8:30:06 [ERROR] mysqld: Table './centreon_storage/logs' is marked as crashed and should be repaired
Jun 8 08:30:06 cloro mysqld: 180608 8:30:06 [Warning] Checking table: './centreon_storage/logs'
Jun 8 08:30:10 cloro mysqld: 2018-06-08 08:30:10 7f13ad17c700 InnoDB: Assertion failure in thread 139722485122816 in file btr0cur.cc line 332
Jun 8 08:30:10 cloro mysqld: InnoDB: Failing assertion: btr_page_get_prev(get_block->frame, mtr) == page_get_page_no(page)
Jun 8 08:30:10 cloro mysqld: InnoDB: We intentionally generate a memory trap.
Jun 8 08:30:10 cloro mysqld: InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
Jun 8 08:30:10 cloro mysqld: InnoDB: If you get repeated assertion failures or crashes, even
Jun 8 08:30:10 cloro mysqld: InnoDB: immediately after the mysqld startup, there may be
Jun 8 08:30:10 cloro mysqld: InnoDB: corruption in the InnoDB tablespace. Please refer to
Jun 8 08:30:10 cloro mysqld: InnoDB: http://dev.mysql.com/doc/refman/5.6/en/ ... overy.html
Jun 8 08:30:10 cloro mysqld: InnoDB: about forcing recovery.
Jun 8 08:30:10 cloro mysqld: 180608 8:30:10 [ERROR] mysqld got signal 6 ;
Jun 8 08:30:10 cloro mysqld: This could be because you hit a bug. It is also possible that this binary
Jun 8 08:30:10 cloro mysqld: or one of the libraries it was linked against is corrupt, improperly built,
Jun 8 08:30:10 cloro mysqld: or misconfigured. This error can also be caused by malfunctioning hardware.

ma se faccio myisamchk /var/lib/mysql/centreon_storage/logs.MYI
Checking MyISAM file: /var/lib/mysql/centreon_storage/logs.MYI
Data records: 1072973 Deleted blocks: 0
- check file-size
- check record delete-chain
- check key delete-chain
- check index reference
- check data record references index: 1
- check data record references index: 2
- check data record references index: 3
- check data record references index: 4
- check data record references index: 5
- check data record references index: 6
- check data record references index: 7
- check data record references index: 8
- check data record references index: 9
- check data record references index: 10
- check record links

e se controllo la tabella con phpmyadmin mi dice che è ok

poi, avviando mysqltuner
[!!] Log file /var/lib/mysql/cloro.err is empty

in my.cnf c'è
general_log_file = /var/log/mysql/general.log
general_log = 1
log_error = /var/log/mysql/error.log


ps aux
root 599 0.3 0.2 24988 6268 ? S giu07 4:15 /bin/bash /usr/bin/mysqld_safe
mysql 16954 0.9 5.8 1612936 181808 ? Sl 08:30 0:10 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --plugin-dir=/usr/lib/mysql/plugin --user=mysql --skip-log-error --pid-file=/var/run/mysqld/mysqld.pid --socket=/var/run/mysqld/mysqld.sock --port=3306
root 16955 0.0 0.0 23720 2392 ? S 08:30 0:00 logger -t mysqld -p daemon.error


infine da dentro il db
+-------------------------------------------+--------------------------------------------------------------------------------------------------------------+
| Variable_name | Value |
+-------------------------------------------+--------------------------------------------------------------------------------------------------------------+
| general_log | OFF |
| general_log_file | cloro.log |
| log_error | |
+-------------------------------------------+--------------------------------------------------------------------------------------------------------------+


quindi, in conclusione, non capisco:
1. sta tabella, è corrotta o no?
2. sti log, sono attivi o no?
3. il file di conf, viene letto o no?

forse c'è stato qualche casino nel passaggio da mysql a mariadb?
grazie
Categorie: Forum Debianizzati

apt-get autoremove

Gio, 07/06/2018 - 16:32
Ciao a tutti, sto sperimentando ansible.
Tramite ansible ho installato apche2 su 3 host.
Ho poi rimosso il pacchetto, sempre tramite ansible, specificando l'opzione purge.
Ho notato però che le dipendenze di apache non sono state rimosse.
aptitude search apache2 | grep ^id
id  apache2-bin                     - Apache HTTP Server (modules and other bina
id  apache2-data                    - Apache HTTP Server (common files)
id  apache2-utils                   - Apache HTTP Server (utility programs for w

Presumo che ansible abbia usato apt-get (che non rimuove le dipendenze allo stesso modo di aptitude).
Ad ogni modo, quello che non mi spiego è questo:
apt-get autoremove
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
0 aggiornati, 0 installati, 0 da rimuovere e 48 non aggiornati.

ovvero non fa nulla.

Il flag 'id' mostrato da aptitude significa "i che indica che il pacchetto verrà installato, d che indica che il pacchetto verrà rimosso".
Se questi pacchetti non vengono rimossi da apt-get autoclean, quando/come dovrebbero essere rimossi?

Per completezza, gli host su cui è stato installato apache2 sono delle ubuntu 16.04 mentre ansible 2.5.1
è stato installato ed eseguito da una ubuntu 18.04.

Grazie.
Categorie: Forum Debianizzati

Gnome internships

Lun, 04/06/2018 - 13:14
Offerte di lavoro da GNOME Foundation
https://wiki.gnome.org/Internships
Categorie: Forum Debianizzati

Re: Donazioni

Lun, 04/06/2018 - 13:03
Se tutti facessimo donazioni anche minime, ci sentiremmo meno in vergogna ad usare software libero "a gratis".
Vedi quest'altro filantropo, donato 1 (uno) MILIONE di dollari a Gnome Foundation:
https://www.gnome.org/news/2018/05/anonymous-donor-pledges-1m-donation-over-two-years/
Categorie: Forum Debianizzati

Re: ftp.it.debian.org/ estremamente lento

Dom, 03/06/2018 - 22:32
origrafica ha scritto:Si è data una causa senza formulare una soluzione. Non mi pare risolto
La soluzione è semplice: non usare il protocollo ftp. Se, al contrario, usi il protocollo http, come sembrerebbe dalla configurazione dell’ultimo messaggio e precedentemente non specificato, dal log che hai inviato nel primo messaggio sembra ci sia un malfunzionamento del DNS (probabilmente del client DNS del tuo computer) poiché gli indirizzi sono risolti in ipv6 e non in ipv4. Controlla la configurazione del client DNS e/o utilizza il comando dig (del pacchetto dnsutils) per verificare da quale server è risolto l'indirizzo del repository ed in che modo:
script log.txt
dig ftp.it.debian.org
exit
Categorie: Forum Debianizzati

Re: ftp.it.debian.org/ estremamente lento

Dom, 03/06/2018 - 19:27
Aki ha scritto:intervento di moderazione: si contrassegna la discussione come risolta.

Si è data una causa senza formulare una soluzione.
Non mi pare risolto
Categorie: Forum Debianizzati

Re: [RISOLTO] ftp.it.debian.org/ estremamente lento

Dom, 03/06/2018 - 19:25
Scusate, di grazia, in dunque cosa dovrei cambiare i repository?

# Debian 9 (Stretch)
deb http://ftp.it.debian.org/debian/ stretch main contrib non-free
deb-src http://ftp.it.debian.org/debian/ stretch main contrib non-free

# Aggiornamenti di sicurezza per Stretch
deb http://security.debian.org/ stretch/updates main contrib non-free
deb-src http://security.debian.org/ stretch/updates main contrib non-free

# stretch-updates, previously known as 'volatile'
deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
deb-src http://deb.debian.org/debian/ stretch-updates main contrib non-free

# Backports
deb http://deb.debian.org/debian stretch-backports main contrib

# Spotify
deb http://repository.spotify.com stable non-free



Questo il mio sources.list che genera quei rallentamenti/errori

Grazie
Categorie: Forum Debianizzati

Re: Correggere spectre e meltdown su nuovo computer

Dom, 03/06/2018 - 17:59
Inserisco qui una domanda: sapete se e quando verranno portate le patch per Meltdown e Spectre anche sui kernel a 32 bit? Sinceramente vorrei evitare di piallare un sistema in piedi da più di 10 anni per questa cosa...

Grazie.
Categorie: Forum Debianizzati

Re: Vlc non avvia interfaccia grafica

Dom, 03/06/2018 - 10:57
crysaltis ha scritto:vorrei usare la schermata di Gnome 3 quella di default per intenderci, [..] il software si avvia, se provo ad aprire un film, sento l' audio normalmente e se verifico i processi in esecuzione mi esce anche VLC, però non avvia nessun video, ovvero non è che mi esce schermata nera o altro, è proprio l' interfaccia grafica di vlc che non si avvia.
Per meglio capire, purtroppo sarebbe utile avere i log richiesti, sia dell'installazione (vedi mio messaggio precedente) che di vlc avviato da console di gnome3 con l'opzione di debug attiva.
Categorie: Forum Debianizzati

Re: Correggere spectre e meltdown su nuovo computer

Dom, 03/06/2018 - 10:47
jnbian ha scritto:Per quanto riguarda le modifiche al kernel invece, installando debian testing il kernel dovrebbe già avere le correzioni, se decidessi di installare la stable queste modifiche sono già presenti anche nel suo kernel?


jnbian ha scritto:vari programmi per rilevare i bug, cerco tra le discussioni quali sono questi programmi.
I programmi servono a verificare se il sistema operativo risulta essere potenzialmente vulnerabile. Per Debian Testing c'è uno specifico pacchetto chiamato spectre-meltdown-checker. Per i sistemi operativi proprietari, non è oggetto di approfondimento di questo forum, ma anche la Microsoft, ad esempio, ha sviluppato programmi analoghi: una ricerca con google potrà fornirti maggiori elementi.

Quando possibile, per cortesia, aggiorna la discussione rispetto al quesito posto per Debian.
Categorie: Forum Debianizzati

Re: Correggere spectre e meltdown su nuovo computer

Sab, 02/06/2018 - 20:36
Grazie per la risposta.
In pratica posso procedere con l'aggiornamento del bios.
Per quanto riguarda le modifiche al kernel invece, installando debian testing il kernel dovrebbe già avere le correzioni, se decidessi di installare la stable queste modifiche sono già presenti anche nel suo kernel?

Comunque se ho capito bene devo procedere con l'installazione di entrambe i sistemi operativi ed poi eseguire i vari programmi per rilevare i bug, cerco tra le discussioni quali sono questi programmi.

Grazie.
Categorie: Forum Debianizzati

Re: Installare win10 e debian9 in dual boot su diversi hard

Sab, 02/06/2018 - 18:07
@lbardo: torno a chiederti se cortesemente puoi aggiornare la discussione
Categorie: Forum Debianizzati

Re: aggiornamento da DEBIAN 8 a DEBIAN 9 spazio necessario

Sab, 02/06/2018 - 18:03
intervento di moderazione: si contrassegna la discussione risolta in assenza di riscontro (richiesto) all'utente e della adeguatezza delle risposte fornite a parere dello scrivente.
Categorie: Forum Debianizzati

Re: Messaggi d'errore dopo installazione su SSD

Sab, 02/06/2018 - 18:02
@paolo-m: hai ulteriormente approfondito i messaggi di errore che hai segnalato nel precedente messaggio ?
Categorie: Forum Debianizzati

Re: installazione grub in dual boot

Sab, 02/06/2018 - 17:36
debon ha scritto:ho provato a reinstallare grub da terminale
root@lubuntu:~# mount/dev/sdb6 /mnt
root@lubuntu:~# mount --bind /dev /mnt/dev
root@lubuntu:~# mount --bind /proc /mnt/proc
root@lubuntu:~# mount --bind /sys /mnt/sys
root@lubuntu:~# chroot /mnt
root@lubuntu:/# grub-install /dev/sdb
Installing for i386-pc platform.

[..]grazie a tutti e spero di non finire offtopic anche sta volta
Ciao debon, ho riformattato il tuo primo messaggio in modo da includere i log tra tag CODE.

Dai log che hai inviato risulta "Installing for i386-pc platform": hai installato una versione di Debian a 32 bit o a 64 bit ? Stai usando un supporto di ripristino Debian per diversa architettura rispetto a quella installata ?

Inoltre, sempre dai log, risulta che hai installato Debian nel disco /dev/sdb e che nel tuo computer è presente un disco /dev/sda di non meglio precisata funzione (un acceleratore a stato solido ?).

Pertanto, il boot loader UEFI di Debian dovrebbe essere installato nella partizione EFI di /dev/sdb , come hai giustamente tentato di fare. Per meglio verificare, dovresti, avviato il computer dal disco di rescue come hai documentato, impartire i comandi indicati in https://wiki.debian.org/GrubEFIReinstall#Reinstalling_grub-efi_on_your_hard_drive considerando che l'esempio di cui al link che ti ho indicato utilizza come disco /dev/sda e non /dev/sdb; in buona sostanza i comandi da impartire come utente root sarebbero, dopo avvio del sistema da supporto di rescue con i comandi indicati nel precedente messaggio:
script log.txt
[ -d /sys/firmware/efi ] && echo "EFI boot on HDD" || echo "Legacy boot on HDD"
mount /dev/sdb2 /boot/efi
[ -d /boot/efi ] && echo "/boot/efi exists" || mkdir -p /boot/efi
apt-get install --reinstall grub-efi
grub-install /dev/sdb
update-grub
file /boot/efi/EFI/debian/grub*
efibootmgr --verbose | grep debian
exit

I comandi impartiti ed i relativi log saranno nel file log.txt che potrai copiare, ad esempio, su un supporto USB esterno ed inviare in un prossimo messaggio del forum: sarebbe utile poterli visionare per poterti aiutare.

post scriptum: se non l'avessi capito, la tua precedente discussione è stata spostata in off-topic perché chiedeva istruzioni su come installare un sistema operativo proprietario
Categorie: Forum Debianizzati