Forum Debianizzati

Condividi contenuti
Aggiornato: 1 ora 42 min fa

Re: Purism is Crowdfunding an Encrypted Linux Phone

Lun, 04/09/2017 - 12:18
marcomg ha scritto:Tu cosa intenti per desktop? Sistemi ATX?

marcomg ha scritto:Come potenza di calcolo gli smartphone ne hanno più che a sufficienza. Ma sinceramente non vedo il problema di utilizzare sistemi integrati (single board computers) se quello che si cerca non è la scalabilità. Mi faccio un monitor, ci appendo dietro una scatolina e ci collego mouse, tastiera e alimentatore ed ho tutto. Dopo 4 anni che è obsoleta la sostituisco (ma tanto in un PC classico dopo 4 anni se lo vuoi rifare non devi cambiare tutto? voglio dire tanto la CPU ha un socket non compatibile con la scheda madre, le ram sono vecchie e di tecnologia obsoleta, la scheda video è superata, che tieni? Alimentatore se lo hai comprato buono e i dischi (ma alla fine i dischi li cambi e li ricicli ad altri scopi)).
I consumi energetici sono super ridotti, i rumori sono praticamente a zero, direi ottimo


Per “desktop” intendo sistemi assemblabili dunque ATX, mini ATX ecc. Un all in one o in generale i portatili più nuovi hanno sempre meno componenti sostituibili, batterie non estraibili o ram saldate sulla scheda madre. Secondo me questo conduce prematuramente all’obsolescenza, se l’alimentatore ed i dischi sono buoni devo buttarli solo perché il processore inizia ad essere vecchio. Uno dei motivi per cui mi sono avvicinato volentieri al mondo Linux è la possibilità di combattere l’obsolescenza del software chiuso, spesso si vedono sistemi pesanti che ti costringono a cambiare macchina… con linux questo è più difficile ma se poi mi “ingabbio” da solo comprando hardware non modulare ho vanificato tutto.


marcomg ha scritto:Si, ma a parte sprecare un buon hardware che releghi ad un solo scopo (quando potresti utilizzarlo perfettamente anche per tutte le funzioni di un PC) che cambia? Il 99,9% dei giochi in commercio funzionano per windows e sono proprietari (e già è facilissimo craccarli così, immaginati se fossero a codice aperto, le case rischierebbero di vedersi giochi funzionanti )
Questa è una cosa a cui non avevo assolutamente pensato!

marcomg ha scritto:Di questo non ho paura
https://plasma-mobile.org/ (compatibile con nexus 5)
https://www.udoo.org/getting-started/ (compatibile con android, gnu/linux, frebsd e windows)
Questi due progetti sono semplicemente fantastici! Una domanda: come mai vedi di buon occhio il progetto “plasma-mobile” mentre “Purism”, il progetto che ho linkato io, pensi che abbia meno prospettive?
Categorie: Forum Debianizzati

Re: grub:lungo tempo attesa apparizione menu

Lun, 04/09/2017 - 07:56
caturen ha scritto: No! Non puoi formattare solo una parte del disco.non ho idea se "funzioni", ma ho trovato questoThere is an easy way to erase (format) your MBR in Linux, using the dd command.

The following steps should not be taken lightly, and you should always have a backup of your data before attempting such things!
To format just your MBR

dd if=/dev/zero of=/dev/sda bs=446 count=1
... where /dev/sda is the drive you want to remove the MBR from. e la stessa cosa viene detta qui https://www.cyberciti.biz/faq/linux-cle ... d-command/

Ok, certo che l' MBR puoi sovrascriverlo e/o formattarlo, ogni volta che reinstalli grub succede. Anche una qualsiasi partizione definita nel disco puoi formattarla.
Scusa ma ho risposto un po' affrettatamente, pensando che ti ti riferissi esclusivamente ai filesystem.
Comunque il tuo problema non è nell'MBR, è proprio nei filesystem che contengono settori danneggiati.
Grub si avvia correttamente, poi però quando cerca di accedere/caricare files contenuti in settori difettosi si pianta.
Riguardo al disco esterno usb, ti assicuro che il disco all'interno del case è un normalissimo disco con connettre sata o se un po' datato ide. Quindi smontarlo e collegarlo al controller della mainboard è solo questione di competenza/pazienza e se si tratta di dischi da 2,5" di procurarsi un paio di adattatori.
Categorie: Forum Debianizzati

Re: grub:lungo tempo attesa apparizione menu

Dom, 03/09/2017 - 23:52
c'era anche questo che credo sia importante
SMART Self-test log structure revision number 1
Num  Test_Description    Status                  Remaining  LifeTime(hours)  LBA_of_first_error
# 1  Short offline       Completed: read failure       90%     24179         228274402
# 2  Extended offline    Completed: read failure       90%     24178         228274402
# 3  Extended offline    Completed: read failure       90%     23860         228274402
# 4  Extended offline    Completed: read failure       90%     23788         228274402
# 5  Extended offline    Completed: read failure       90%     23252         228274402
# 6  Extended offline    Completed: read failure       90%     22884         228274402
# 7  Extended offline    Completed: read failure       90%     22527         228274402
# 8  Extended offline    Completed: read failure       90%     22009         228274402
# 9  Extended offline    Completed: read failure       90%     21590         228274402
#10  Extended offline    Completed: read failure       90%     21189         228274402
#11  Extended offline    Completed: read failure       90%     20759         228274402
#12  Extended offline    Completed without error       00%     20293         -
#13  Extended offline    Interrupted (host reset)      90%     19905         -
#14  Extended offline    Completed without error       00%     19049         -
#15  Extended offline    Interrupted (host reset)      60%     18586         -
#16  Extended offline    Interrupted (host reset)      60%     18102         -
#17  Extended offline    Completed without error       00%     16817         -
#18  Extended offline    Interrupted (host reset)      70%     15991         -
#19  Extended offline    Interrupted (host reset)      90%     15490         -
#20  Extended offline    Interrupted (host reset)      90%     15199         -
#21  Extended offline    Interrupted (host reset)      40%     14680         -
Categorie: Forum Debianizzati

Re: grub:lungo tempo attesa apparizione menu

Dom, 03/09/2017 - 23:51
Prima di tutto grazie dell'aiuto che provate a darmi.
@akiNo, dice una cosa diversa: hai ragione. Ero convinto di ricordarmi un'altra cosa
@bite64
No! Non puoi formattare solo una parte del disco.non ho idea se "funzioni", ma ho trovato questoThere is an easy way to erase (format) your MBR in Linux, using the dd command.

The following steps should not be taken lightly, and you should always have a backup of your data before attempting such things!
To format just your MBR

dd if=/dev/zero of=/dev/sda bs=446 count=1
... where /dev/sda is the drive you want to remove the MBR from. e la stessa cosa viene detta qui https://www.cyberciti.biz/faq/linux-cle ... d-command/
Riguardo al disco usb esterno, puoi sempre smontarlo dal suo "case"non si può fare
Non hai una memoria usb esterna sulla quale mettere una iso live?ho una chiavetta usb già pronta con una live
Un' altra utility che puoi usare per controllare i settori difettosi è badblocks. ci do una occhiata
se può essere utile
root@caturen:/home/caturen# smartctl -a /dev/sda
SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate     0x002f   100   092   062    Pre-fail  Always       -       0
  2 Throughput_Performance  0x0025   100   100   040    Pre-fail  Offline      -       0
  3 Spin_Up_Time            0x0023   214   100   033    Pre-fail  Always       -       1
  4 Start_Stop_Count        0x0032   090   090   000    Old_age   Always       -       16385
  5 Reallocated_Sector_Ct   0x0033   100   100   005    Pre-fail  Always       -       0
  7 Seek_Error_Rate         0x002f   100   100   067    Pre-fail  Always       -       0
  8 Seek_Time_Performance   0x0025   100   100   040    Pre-fail  Offline      -       0
  9 Power_On_Hours          0x0032   045   045   000    Old_age   Always       -       24252
 10 Spin_Retry_Count        0x0033   100   100   060    Pre-fail  Always       -       0
 12 Power_Cycle_Count       0x0032   093   093   000    Old_age   Always       -       12248
183 Runtime_Bad_Block       0x0032   100   100   000    Old_age   Always       -       0
184 End-to-End_Error        0x0033   100   100   097    Pre-fail  Always       -       0
187 Reported_Uncorrect      0x0032   100   095   000    Old_age   Always       -       7275778015237
188 Command_Timeout         0x0032   100   074   000    Old_age   Always       -       12889434184
190 Airflow_Temperature_Cel 0x0022   061   045   045    Old_age   Always   In_the_past 39 (Min/Max 39/43)
191 G-Sense_Error_Rate      0x0032   001   001   000    Old_age   Always       -       61906
192 Power-Off_Retract_Count 0x0032   099   099   000    Old_age   Always       -       19202341
193 Load_Cycle_Count        0x0032   079   079   000    Old_age   Always       -       215396
196 Reallocated_Event_Count 0x0032   100   100   000    Old_age   Always       -       0
197 Current_Pending_Sector  0x0032   100   100   000    Old_age   Always       -       2
198 Offline_Uncorrectable   0x0030   100   100   000    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x0036   100   100   000    Old_age   Always       -       3
223 Load_Retry_Count        0x002a   100   100   000    Old_age   Always       -       0

SMART Error Log Version: 1
ATA Error Count: 32 (device log contains only the most recent five errors)
        CR = Command Register [HEX]
        FR = Features Register [HEX]
        SC = Sector Count Register [HEX]
        SN = Sector Number Register [HEX]
        CL = Cylinder Low Register [HEX]
        CH = Cylinder High Register [HEX]
        DH = Device/Head Register [HEX]
        DC = Device Command Register [HEX]
        ER = Error register [HEX]
        ST = Status register [HEX]
Powered_Up_Time is measured from power on, and printed as
DDd+hh:mm:SS.sss where DD=days, hh=hours, mm=minutes,
SS=sec, and sss=millisec. It "wraps" after 49.710 days.

Error 32 occurred at disk power-on lifetime: 24247 hours (1010 days + 7 hours)
  When the command that caused the error occurred, the device was active or idle.





anche gli errori 31-30-29-28 hanno lo stesso errore e fanno riferimento a questo
  After command completion occurred, registers were:
  ER ST SC SN CL CH DH
  -- -- -- -- -- -- --
  40 51 1e e2 30 9b 0d  Error: UNC 30 sectors at LBA = 0x0d9b30e2 = 228274402
Categorie: Forum Debianizzati

Re: grub:lungo tempo attesa apparizione menu

Dom, 03/09/2017 - 22:41
caturen ha scritto:lì dice che il disco è completamente andato mentre il mio non lo è
No, dice una cosa diversa: "the Hard Drive is failing and needs to be replaced"
Categorie: Forum Debianizzati

Re: grub:lungo tempo attesa apparizione menu

Dom, 03/09/2017 - 20:53
caturen ha scritto:Quello che penso è che si sia danneggiato la parte del disco dove risiede il grub. C'è modo di formattarlo e riscriverci sopra il grub sena formattare l'intero disco?
No! Non puoi formattare solo una parte del disco.
Inoltre per completare il mio post precedente, se hai dei settori danneggiati, questi rimangono danneggiati anche dopo una formattazione, pure se di basso livello.
Vero che i dischi moderni utilizzano dei marcatori per evitare di scrivere sui settori danneggiati, quando riformatti, però se la causa del danneggiamento è un guasto sul controller della testina elettromagnetica del disco, è solo questione di tempo il danneggiamento di nuovi settori. Quindi continuare a formattare non serve a molto, se non a prolungare "l'agonia" del disco.
Riguardo al disco usb esterno, puoi sempre smontarlo dal suo "case" e collegarlo direttamente al controller della scheda madre e fare le prove del caso, superando così gli eventuali limiti del controller usb della tua scheda madre.
Non hai una memoria usb esterna sulla quale mettere una iso live? Sarebbe sufficiente per fare le prove indicate.
Un' altra utility che puoi usare per controllare i settori difettosi è badblocks.
Categorie: Forum Debianizzati

Re: grub:lungo tempo attesa apparizione menu

Dom, 03/09/2017 - 19:35
Scusa, non ho ben compreso: ci stai scrivendo che il diagnostico del BIOS riferisce che il disco interno è malfunzionante e che, come indicato nel link che ci hai riferito, l'assistenza tecnica HP indica "The error codes are for the short and full Disk Self Test and would definitely indicate that the Hard Drive is failing and needs to be replaced. This is also consistent with the start-up issue." ? si continua a toccare ferro.non è questione di fare battute: lì dice che il disco è completamente andato mentre il mio non lo è
A questo punto mi pare doveroso fare un check anche del disco esternopurtroppo smart non è supportato dal disco esternoAnzi il migliore test che potresti fare è di collegare un terzo disco interno, lo so che sarebbe la prova del nove ma non ho un altro hd al momentoa questo punto collegherei prima il disco usb e quindi successivamente anche quello originale interno, poi un test approfondito con hdparm e poi con fsck fsck non da problemi di sorte nei vari sistemi. Per hdparm non ho idea di cosa faccia ci darò una occhiata
Quello che penso è che si sia danneggiato la parte del disco dove risiede il grub. C'è modo di formattarlo e riscriverci sopra il grub sena formattare l'intero disco?
Categorie: Forum Debianizzati

Re: grub:lungo tempo attesa apparizione menu

Dom, 03/09/2017 - 19:09
A questo punto mi pare doveroso fare un check anche del disco esterno, dato che quello interno è quasi certamente danneggiato.
mark ha scritto:questo messaggio non mi sembra molto tranquillizzante, prova a verificare
ago 29 11:36:59 nomehost smartd[521]: Device: /dev/sda [SAT], 2 Currently unreadable (pending) sectors

Anzi il migliore test che potresti fare è di collegare un terzo disco interno, possibilmente nuovo, e provare ad installare un sistema da zero, grub incluso (tenendo scollegati fisicamente sia il disco esterno usb che quello originale interno). Se l'avvio è fluido, l'hardware del pc è a posto, ed a questo punto collegherei prima il disco usb e quindi successivamente anche quello originale interno, poi un test approfondito con hdparm e poi con fsck, su tutti e due.
Puoi anche fare questi due test con una distro live, sia da usb che da cd.
Tieni presente che i settori di un disco, una volta che iniziano a danneggiarsi, spesso si comportano come fosse un'infezione, e le infezioni vanno risolte subito, anche se apparentemente sembrano contenute.
Ciao
Categorie: Forum Debianizzati

Re: Debian 9.1 si blocca

Dom, 03/09/2017 - 18:54
Pietro_1 ha scritto:1) se ho capito bene devo mettere persistent in Storage al posto di auto e questo l'ho fatto.
In caso di malfunzionamento, spegni il computer in modo controllato usando la sequenza di tasti in gergo denominata REISUB (vedi mio precedente messaggio). Al successivo riavvio, nel log del computer potrebbero essere presenti messaggi di errore espressione delle cause del malfunzionamento.
Categorie: Forum Debianizzati

Re: grub:lungo tempo attesa apparizione menu

Dom, 03/09/2017 - 18:51
caturen ha scritto:EDIT: anch'io ho lo stesso esito del test diagnostico del notebook hp, cioè "hard disk 1 full" che ha avuto questo https://h30434.www3.hp.com/t5/Notebook- ... -p/1932921
anche se a me il test veloce non ha dato errori.
Scusa, non ho ben compreso: ci stai scrivendo che il diagnostico del BIOS riferisce che il disco interno è malfunzionante e che, come indicato nel link che ci hai riferito, l'assistenza tecnica HP indica "The error codes are for the short and full Disk Self Test and would definitely indicate that the Hard Drive is failing and needs to be replaced. This is also consistent with the start-up issue." ?

per la verità il mio hard disk non è morto, perchè a parte il grub tutto funziona perfettamente (toccando ferro)
.. continua a toccare ferro.

Ma come mai anche se lo stacco [il disco interno, ndr] il grub del disco esterno rimane in qualche modo corrotto anche se faccio l'update?
E' molto probabile che siano due fenomeni indipendenti.
Categorie: Forum Debianizzati

Re: grub:lungo tempo attesa apparizione menu

Dom, 03/09/2017 - 18:43
Se, come immagino le "scritte in basso nello schermo" sono prodotte dal BIOS (visto che scrivi di una macchina datata), allora vuol dire che il caricamento della prima parte di grub non è a avvenuta oppure si è interrotta, e questo non può che dipendere da come il computer accede al disco esterno oppure da come è stato installato grub nel disco esterno.scusa, mi sono espresso male io. Sono le scritte prodotte dal bios: premere esc per il test oppure f10 per il setup del bios (o qualcosa di simile)A quale disco hai dato la precedenza di avvio ?prima il disco esterno, poi il cd e per ultimo il disco interno
Mi sa tanto che devi rifare così, in attesa del prossimo malfunzionamento.per il momento no dato che attaccando l'hd esterno riesco a far partire tutto con il grub di suseIo aspetto sempre il video relativo alla registrazione del malfunzionamento, se possibile con il BIOS configurato per mostrare tutte le informazioni del boot.te l'ho già scritto che non posso fare video dato che NON ho uno smartphone e tanto meno una telecamera e non vedo cosa un video possa rivelare quando scrivo che appare per qualche istante il menu del bios e poi il nulla assoluto con schermo nero.
Categorie: Forum Debianizzati

Re: grub:lungo tempo attesa apparizione menu

Dom, 03/09/2017 - 18:22
caturen ha scritto: il malfunzionamento dipende dal disco rigido, allora puoi semplicemente sostituire il disco e prenderne uno diverso funzionante per escludere che ne sia la causa.
come ho scritto ho già staccato l'hd interno, fatto partire l'hd esterno usb, aggiornato il grub per non far vedere il disco interno e fatto partire un grub che non sia di suse: all' avvio parte la scritta in basso a sinistra con le combinazioni di avvio poi completamente nulla, schermo nero.
Non mi pare che grub quando si avvia presenti "scritte in basso nello schermo": cosa indicano ? Se, come immagino le "scritte in basso nello schermo" sono prodotte dal BIOS (visto che scrivi di una macchina datata), allora vuol dire che il caricamento della prima parte di grub non è a avvenuta oppure si è interrotta, e questo non può che dipendere da come il computer accede al disco esterno oppure da come è stato installato grub nel disco esterno.

verifica di non aver pasticciato con le impostazione del bios [..] le impostazioni del bios sono rimaste sempre quelle dopo averlo comperato dove ho cambiato solo il disco che ha la precedenza di avvio
A quale disco hai dato la precedenza di avvio ?

[.. verifica che ..] boot-loader siano compatibili con la CPU e la scheda madre questa non l'ho capita. Come fa grub ad essere incompatibile con il sistema, quando sono anni che lo uso in questa configurazione senza aver avuto alcun problema.
Poiché sei alquanto ermetico e non non ha documentato esattamente cosa hai fatto con le diverse distribuzioni che citi, sono costretto ad ipotizzare quello che hai fatto; in ogni caso, se hai reinstallato grub su un disco, potresti anche aver installato una versione incompatibile con la specifica CPU.

Il problema è apparso una prima volta circa due mesi fa sul disco esterno, ma li formattando il tutto e reinstallando si è risolto.
Mi sa tanto che devi rifare così, in attesa del prossimo malfunzionamento.

Ora non ho nessuna voglia di formattare il disco interno per vedere se cancellando tutto e reinstallando il problema si risolve
Mi sa che allora te lo tieni così: buon per te! :-)

Io aspetto sempre il video relativo alla registrazione del malfunzionamento, se possibile con il BIOS configurato per mostrare tutte le informazioni del boot.
Categorie: Forum Debianizzati

Re: grub:lungo tempo attesa apparizione menu

Dom, 03/09/2017 - 17:02
il malfunzionamento dipende dal disco rigido, allora puoi semplicemente sostituire il disco e prenderne uno diverso funzionante per escludere che ne sia la causa.come ho scritto ho già staccato l'hd interno, fatto partire l'hd esterno usb, aggiornato il grub per non far vedere il disco interno e fatto partire un grub che non sia di suse: all' avvio parte la scritta in basso a sinistra con le combinazioni di avvio poi completamente nulla, schermo nero. Le prime volte invece dopo parecchi secondi di attesa appariva il grub con le varie opzioni di avvioverifica di non aver pasticciato con le impostazione del biosle impostazioni del bios sono rimaste sempre quelle dopo averlo comperato dove ho cambiato solo il disco che ha la precedenza di avvio boot-loader siano compatibili con la CPU e la scheda madre questa non l'ho capita. Come fa grub ad essere incompatibile con il sistema, quando sono anni che lo uso in questa configurazione senza aver avuto alcun problema. A parte il problema delle distro che derivano da arch. Il problema è apparso una prima volta circa due mesi fa sul disco esterno, ma li formattando il tutto e reinstallando si è risolto. Ora non ho nessuna voglia di formattare il disco interno per vedere se cancellando tutto e reinstallando il problema si risolve

EDIT: anch'io ho lo stesso esito del test diagnostico del notebook hp, cioè "hard disk 1 full" che ha avuto questo https://h30434.www3.hp.com/t5/Notebook- ... -p/1932921
anche se a me il test veloce non ha dato errori. Ma come mai anche se lo stacco il grub del disco esterno rimane in qualche modo corrotto anche se faccio l'update?If the notebook will not boot into Windows and you get that error from the hard drive test it means the drive is dead. per la verità il mio hard disk non è morto, perchè a parte il grub tutto funziona perfettamente (toccando ferro)
Categorie: Forum Debianizzati

Re: Debian 9.1 si blocca

Dom, 03/09/2017 - 15:11
1) se ho capito bene devo mettere persistent in Storage al posto di auto e questo l'ho fatto.

2) di applicazioni aggiuntive rispetto a quelle di base ho solo installato Librecad e Kicad, il resto è tutto di "serie"

3) diversi giorni fa si è presentato un kernel panic che penso di aver risolto con la funzione recovery del cd d'installazione.

4) ho in dual boot win 10, mi serve per far girare il programma gestionale aziendale

5) all'avvio mi da delle notifiche di cui allego foto. La terza riga all'inizio non mi compariva, da quando ho avviato per la prima volta win 10 è comparsa, sarà un caso?

Questo è il mio quadro in generale...

https://imgur.com/g5ODVYN
Categorie: Forum Debianizzati

Re: grub:lungo tempo attesa apparizione menu

Dom, 03/09/2017 - 14:02
@caturen: se è lapalissiano, gli altri epifenomeni sono solo fattori di confondimento. Se il malfunzionamento dipende dal disco rigido, allora puoi semplicemente sostituire il disco e prenderne uno diverso funzionante per escludere che ne sia la causa. Qualora la causa invece sia a livello di scheda madre, c'è poco da fare. Infine, poiché il caricamento del boot loader dipende fortemente dal firmware del computer, verifica di non aver pasticciato con le impostazione del bios e che i boot-loader siano compatibili con la CPU e la scheda madre.

In ogni caso, se ci fai vedere la registrazione video che ti ho già chiesto (quella nella quale si vede il malfunzionamento) , potrebbe essere utile.
Categorie: Forum Debianizzati

Re: [RISOLTO] creare chiavetta USB avviante -- unetbootin

Dom, 03/09/2017 - 13:18
Sotto windows usate Rufus
Categorie: Forum Debianizzati

Re: [RISOLTO] creare chiavetta USB avviante -- unetbootin

Dom, 03/09/2017 - 12:08
Personalmente preferisco il metodo usando cp da console piuttosto che dd, non so perche' ma mi sta piu' simpatico....

In Ubuntu bisogna installare il creatore di dischi di avvio Usb (che, pero', crea uno schema di partizioni assurdo....), UnetBootIn non mi ha mai funzionato ne' sotto Win, ne' sotto Mac ne' sotto Linux, qualsiasi distro, ora comincia a dare problemi anche Universal Usb Installer sotto Win (ma credo che sia colpa di M$, non di UUI).
Categorie: Forum Debianizzati

Re: Installare driver per ubuntu su debian

Dom, 03/09/2017 - 12:00
Risposta facile e veloce: no

Risposta completa:
anzitutto Debian ed Ubuntu non sono compatibili in termini di file binari, quindi non e' possibile prendere un .deb dai repository di una distro ed installarli nell'altra.
Poi c'e' da considerare altre due cose:
il grosso del codice dei driver open e' derivato da quelli per Win ma, cosa molto piu' importante, Amd, dopo molta insistenza della comunita' opensource, ha deciso di rilasciare i codici in forma open (tranne una piccola parte di base, che fa la differenza tra il driver standard, o free, e quello pro), bisogna solo attendere che la propria scheda sia supportata.
Avevo questo problema anche con XUbuntu (ho una Sapphire Toxic Ati Radeon R9 270x).

Quello che dobbiamo fare e' abilitare i software proprietari (puoi farlo sia da Syanptic che editando il file /etc/apt/sources.list), installare il driver open ed attendere che Ati supporti ufficialmente il nostro chip.
Se e quando lo fara' decideremo se passare a quello ufficiale o restare con il nostro.

Un'altra cosa che possiamo fare e' pubblicizzare Ati, visto che nVidia ha fatto orecchie da mercante....
Categorie: Forum Debianizzati

Re: Liste in C

Dom, 03/09/2017 - 11:42
Grazie

Ne approfitto per fare una correzione ed una precisazione (ho scritto di fretta prima di uscire....):
- il prototipo della funzione headInsert va modificato passando il primo argomento (la lista vera e propria) per riferimento, altrimenti non viene inserito nulla nella lista stessa perche' il parametro sara' passato per valore e sara' una copia, non l'originale, quindi: void headInsert(list &l, list n)
- il secondo parametro l'ho passato come puntatore al nodo per semplificare il codice, ma si potrebbe passare il nodo e poi appiccicargli un puntatore dentro la funzione headInsert; questo si puo' passare sia per valore che per riferimento a scelta del programmatore, il programma funziona lo stesso, passando per riferimento risparmio memoria ed il tempo della copia, passandolo per valore qualcuno lo considera piu' safe
Categorie: Forum Debianizzati