Forum Debianizzati

Condividi contenuti
Aggiornato: 37 min 36 sec fa

Re: Trovare applicazione che invia dati

Lun, 18/12/2017 - 11:43
ferdybassi ha scritto:Ma che server è?
Cosa fa?
A me era capitata una cosa del genere su un server Apache, si era messo a inviare tonnellate di mail.
Avevo risolto:
- impedendo che l'utente www-data potesse inviare email (per tamponare la cosa in attesa di trovare il problema)
- cercando lo script che inviava mail
Era saltato fuori che avevano bucato il Joomla di un cliente, che non aveva aggiornato né il core né i plugin.
Mi ero fatto un paio di appunti:
http://guide.debianizzati.org/index.php ... ver_Apache
http://guide.debianizzati.org/index.php ... viano_SPAM

Ciao

E' un server di CRM (PHP) su cui è installato un'ambiente Java con una serie di applicazioni di utilità e reportistica.
Venerdì sera notai tanti collegamenti anomali che avevano come sorgente mysql e quindi per ora ho chiuso l'accesso a MySQL dall'esterno (non serviva più) facendo bind su 127.0.0.1

Ora provvedo a fare un hardening del server come consigliato e ne approfitto per farti i complimenti per la soluzione email, davvero semplice e geniale.

Grazie mille. Appena riesco a capire meglio cosa è successo o cambia qualcosa vi aggiorno
Categorie: Forum Debianizzati

Re: Trovare applicazione che invia dati

Lun, 18/12/2017 - 11:36
byte64 ha scritto:Puoi provare con chkrootkit e/o rkhunter.
Sono entrmabi pacchettizati per debian.
Se trovi qualche cosa, magari informaci......è sempre utile avere info su eventuali rootkit che girano.

Ciao

Grazie per l'aiuto. Purtroppo non mi sembra che esca fuori qualcosa di sospetto
Categorie: Forum Debianizzati

Consiglio per scheda audio PCI o USB

Lun, 18/12/2017 - 09:54
Ciao,

Da ieri la mia scheda audio SB0570 (SoundBlaster Audigy PCI) sta cominciando a fare ronzii e strani "crack". Sospetto che mi stia per lasciare, ho fatto quasi tutte le prove, l'unica che mi manca è quella di spostarla sull'unico altro slot PCI che mi rimane (al momento occupato dalla scheda wi-fi).
Ho anche una scheda audio integrata (HDA INTEL ALC888) ma riesco a sentire solamente l'altoparlante destro.
Quindi probabilmente dovrò sostituirla con un'altra scheda.

Esiste qualcosa di economico, anche USB, che funzioni bene con Debian? L'importante è poter inserire il jack audio delle casse.

Grazie
Categorie: Forum Debianizzati

Re: Trovare applicazione che invia dati

Lun, 18/12/2017 - 09:46
Ma che server è?
Cosa fa?
A me era capitata una cosa del genere su un server Apache, si era messo a inviare tonnellate di mail.
Avevo risolto:
- impedendo che l'utente www-data potesse inviare email (per tamponare la cosa in attesa di trovare il problema)
- cercando lo script che inviava mail
Era saltato fuori che avevano bucato il Joomla di un cliente, che non aveva aggiornato né il core né i plugin.
Mi ero fatto un paio di appunti:
http://guide.debianizzati.org/index.php ... ver_Apache
http://guide.debianizzati.org/index.php ... viano_SPAM

Ciao
Categorie: Forum Debianizzati

Re: Trovare applicazione che invia dati

Lun, 18/12/2017 - 09:46
Ma che server è?
Cosa fa?
A me era capitata una cosa del genere su un server Apache, si era messo a inviare tonnellate di mail.
Avevo risolto:
- impedendo che l'utente www-data potesse inviare email (per tamponare la cosa in attesa di trovare il problema)
- cercando lo script che inviava mail
Era saltato fuori che avevano bucato il Joomla di un cliente, che non aveva aggiornato né il core né i plugin.
Mi ero fatto un paio di appunti:
http://guide.debianizzati.org/index.php ... ver_Apache
http://guide.debianizzati.org/index.php ... viano_SPAM

Ciao
Categorie: Forum Debianizzati

Re: Stampante HP Laserjet Pro MFP M130nw - "sfondo grigio"

Lun, 18/12/2017 - 01:33
Aki ha scritto:@starkdeb:
la versione 3.16.11+repack0-3 di hplip in Debian 9 non supporta la stampante in oggetto (non ha il ppd previsto).

Hai, quindi, probabilmente ottenuto il PPD scaricando dalla rete una versione del PPD oppure una versione di HPLIP più recente (il supporto è disponibile nella versione 3.17 che è presente a partire da Debian Testing, vedi PPD allegato): sarebbe stato molto utile che lo avessi indicato nel primo messaggio, in quanto avrebbe consentito di arrivare molto più rapidamente a questo punto.

il problema di essere un utente di "basso livello" è proprio questo, non sai quali e quante cose possano essere utili ai più esperti per aiutarti al meglio

Aki ha scritto:In ogni caso, il PPD che hai installato (e che definisce le proprietà della stampante, vedi allegato) identifica la stampante come in grado di stampare a colori attraverso la proprietà ColorDevice e DefaultColorSpace

[...]

Probabilmente, la causa di quanto ti accade è correlato a questo. Le specifiche del formatto PPD indicano:
*ColorDevice: True | False
This keyword indicates whether or not the device physically outputs color.
See *Extensions for information about black and white devices that support the
color extensions to the PostScript language. The value is of type StringValue.

*DefaultColorSpace: colorspaceOption
This keyword indicates the default native color space of the device. The
native color space is the color space that all colors are converted into before
rendering. The currently registered values for colorspaceOption (a StringValue)
are
• CMY—This device uses the cyan-magenta-yellow color space as its native
color space.
• CMYK— This device uses the cyan-magenta-yellow-black color space as its
native color space.
• RGB—This device uses the red-green-blue color space as its native color
space.
• Gray—This device uses a gray-scale native color space.

Puoi, pertanto, provare ad agire su tali parametri di configurazione per eliminare il malfunzionamento (oppure provare ricompilare per Debian 9 la versione di Debian Testing).

Proverò a farlo non appena ne avrò la possibilità. Riguardo a compilare o ricompilare qualcosa... aiuto aiuto... non è veramente pane per i miei denti. In quasi dieci anni di utenza Linux non sono riuscito nemmeno a imparare come si manipola un tar.gz... sono negato proprio... non ridete... non riesco a entrare in sintonia con la "logica" dell'informatica.
Spero che lascerete la discussione aperta, nel frattempo cercherò di ricostruire alcuni passi di quello che ho fatto i giorni scorsi. Non è un bel modo di lavorare lo so, ho cercato di arrangiarmi visto che in precedenza con HP ed Epson era andata bene.
Grazie a tutti del vostro contributo.

p.s. per dovere di informazione non sono messo bene con l'inglese "tecnologico"...
Categorie: Forum Debianizzati

Re: Stampante HP Laserjet Pro MFP M130nw - "sfondo grigio"

Lun, 18/12/2017 - 01:16
dring ha scritto:non ho capito con che tipo di documenti hai provato a stampare.
Io proverei vari tipi ad es.: pdf, odt, jpg, png.
la stampante può stampare pagine di prova tipo "Cleaning mode option"? se sì che risultato?


ho provato a stampare sia pdf che odt, e anche la pagine di test della stampante: il risultato è sempre quello. Tranne quando il tecnico l'ha fatta stampare sotto Windows, l'inconveniente accade solo con Debian. Ho provato a setacciare il cd fornito a corredo cercando eventuali file utili per Linux ma non ho trovato nulla.
Categorie: Forum Debianizzati

Re: Stampante HP Laserjet Pro MFP M130nw - "sfondo grigio"

Lun, 18/12/2017 - 01:11
Aki ha scritto:@starkdeb:
Se possibile, sarebbe utile fornire un file di esempio che, riprodotto sulla Tua stampante, genera il comportamento che hai riferito.

Purtroppo stamattina sono dovuto ripartire, non potrò più mettere mano alla stampante per un paio di mesi, mi spiace. Spero che la discussione possa essere lasciata aperta, la riprenderò appena tornerò da quelle parti (quasi 400 km da qui).
Ora cercherò di rispondere alle vostre richieste di chiarimenti.

Aki ha scritto:Inoltre, sarebbe utile sapere come configuri la stampante, cioè se la configuri dall'interfaccia web di CUPS oppure dall'interfaccia dell'ambiente grafico che hai installato (in tal caso, quale e se puoi fornire gli screen-shot della configurazione).

ecco qui sicuramente ho messo mano un po' di qua un po' di là... senza tenere bene a mente, questa è una colpa.

Aki ha scritto:quanto riferito potrebbe essere conseguente alla presenza nella configurazione della stampante di una opzione relativa alla gestione del colore (hai attivato la stampa a colori o stampi a colori dal programma con cui stampi ?), per cui nel rendering del documento (conversione dal formato utilizzato dal programma che stampa, a PDF - internamente a CUPS - e da PDF al linguaggio di stampa utilizzato dalla stampante) il colore chiaro del fondo del documento è rappresentato con un qualche livello di grigio

sinceramente l'impressione, esteticamente parlando, è proprio questa ovvero che il fondo bianco venga rappresentato con un livello di grigio tipo quando si fanno le fotocopie. Devo però dire che pur avendo messo mano alle impostazioni un po' di qua un po' di là, ho sempre selezionato le diciture "monochrome" o "greyscale" ipotozzando che la stampante potesse lavorare a colori.

Aki ha scritto:Per fornire ulteriori elementi, se possibile, impartisci i seguenti ulteriori comandi come utente root dopo aver acceso la stampante:
script log.txt

# aumenta il livello di log
cupsctl LogLevel=debug2
systemctl restart cups

# verifica stampante predefinita
lpstat -d

# invia e stampa una pagina di test
lp /usr/share/cups/data/default-testpage.pdf

# disabilita la stampante di dafault
cupsdisable $(lpstat -d | cut -d':' -f2)

# invia una pagina di test in stampa
lp /usr/share/cups/data/default-testpage.pdf

# visualizza la coda di stampa e copia i file in coda di stampa
lpq
ls /var/spool/cups -la
file /var/spool/cups/d*
cp /var/spool/cups/d* ~/

# riabilita la stampante (stampa la pagina di test)
cupsenable $(lpstat -d | cut -d':' -f2)

# riabilita la stampante di dafault (dovrebbe stampare la pagina di test)
cat /var/log/cups/error_log

# abbassa il livello di dettaglio dei log
cupsctl --no-debug-logging

exit

Quindi, invia il file log.txt ed i file d* che si trovano nella home dalla utenza di root.

Inoltre, potresti indicare se le pagine di test stampate sono affette dallo "sfondo grigio" ?

Inoltre, il file /etc/cups/ppd/HP_LaserJet_MFP_M129-M134.ppd sembrerebbe non essere nei repository Debian: da dove lo hai preso ? Puoi inviare questo file ?

Dunque: le pagine di test e qualsiasi altra pagina stampata sotto Debian sono affette da sfondo grigio; il file cups l'ho reperito in rete se non ricordo male dopo aver cercato un driver HP sia ufficiale sia nei repo debian sono stato reindirizzato mi pare sul sito di Cups e da lì lo ho scaricato come fatto anche anni fa per un'altra stampante hp. Devo però provare a ricostruire passo passo la mia ricerca, ti aggiornerò i prossimi giorni e cercherò di inviarlo.

[EDIT] se non erro però a un certo punto ero talmente incasinato che non stampava addirittura più nulla... ho disinstallato sia hplip e cups utilizzando synaptic e poi li ho reinstallati da lì... quando si dice fare un lavoro coi piedi...
Categorie: Forum Debianizzati

Re: Stampante HP Laserjet Pro MFP M130nw - "sfondo grigio"

Dom, 17/12/2017 - 20:54
non ho capito con che tipo di documenti hai provato a stampare.
Io proverei vari tipi ad es.: pdf, odt, jpg, png.
la stampante può stampare pagine di prova tipo "Cleaning mode option"? se sì che risultato?

su HP
https://sourceforge.net/p/hplip/mailman/hplip-help/?viewmonth=200705&viewday=18

c'è questo vecchio bug di Debian del 2010 che forse può dare indicazioni:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=580963
Categorie: Forum Debianizzati

Re: Stampante HP Laserjet Pro MFP M130nw - "sfondo grigio"

Dom, 17/12/2017 - 13:22
@starkdeb:
la versione 3.16.11+repack0-3 di hplip in Debian 9 non supporta la stampante in oggetto (non ha il ppd previsto).

Hai, quindi, probabilmente ottenuto il PPD scaricando dalla rete una versione del PPD oppure una versione di HPLIP più recente (il supporto è disponibile nella versione 3.17 che è presente a partire da Debian Testing, vedi PPD allegato): sarebbe stato molto utile che lo avessi indicato nel primo messaggio, in quanto avrebbe consentito di arrivare molto più rapidamente a questo punto.

In ogni caso, il PPD che hai installato (e che definisce le proprietà della stampante, vedi allegato) identifica la stampante come in grado di stampare a colori attraverso la proprietà ColorDevice e DefaultColorSpace:
*PPD-Adobe: "4.3"
*%%%% PPD file for HP LaserJet MFP m129-m134 with CUPS.
*%%%% Created by the CUPS PPD Compiler CUPS v1.5.0.
*% (c) 2008 Copyright HP Development Company, LP
*FormatVersion: "4.3"
*FileVersion: "3.17.11"
*LanguageVersion: English
*LanguageEncoding: ISOLatin1
*PCFileName: "hp-laserjet_mfp_m129-m134.ppd"
*Product: "(HP LaserJet Pro MFP m132a)"
*Product: "(HP LaserJet Pro MFP m132nw)"
*Product: "(HP LaserJet Pro MFP m132snw)"
*Product: "(HP LaserJet Pro MFP m134a)"
*Product: "(HP LaserJet Pro MFP m132fw)"
*Product: "(HP LaserJet Pro MFP m132fn)"
*Product: "(HP LaserJet Pro MFP m132fp)"
*Product: "(HP LaserJet Pro MFP m134fn)"
*Product: "(HP LaserJet Pro MFP m130a)"
*Product: "(HP LaserJet Pro MFP m130nw)"
*Product: "(HP LaserJet Pro MFP m130fn)"
*Product: "(HP LaserJet Pro MFP m130fw)"
*Manufacturer: "HP"
*ModelName: "HP LaserJet MFP m129-m134"
*ShortNickName: "HP LaserJet MFP m129-m134 hpijs"
*NickName: "HP LaserJet MFP m129-m134, hpcups 3.17.11"
*PSVersion: "(3010.000) 0"
*LanguageLevel: "3"
*ColorDevice: True
*DefaultColorSpace: RGB

[..continua..]


Probabilmente, la causa di quanto ti accade è correlato a questo. Le specifiche del formatto PPD indicano:
*ColorDevice: True | False
This keyword indicates whether or not the device physically outputs color.
See *Extensions for information about black and white devices that support the
color extensions to the PostScript language. The value is of type StringValue.

*DefaultColorSpace: colorspaceOption
This keyword indicates the default native color space of the device. The
native color space is the color space that all colors are converted into before
rendering. The currently registered values for colorspaceOption (a StringValue)
are
• CMY—This device uses the cyan-magenta-yellow color space as its native
color space.
• CMYK— This device uses the cyan-magenta-yellow-black color space as its
native color space.
• RGB—This device uses the red-green-blue color space as its native color
space.
• Gray—This device uses a gray-scale native color space.

Puoi, pertanto, provare ad agire su tali parametri di configurazione per eliminare il malfunzionamento (oppure provare ricompilare per Debian 9 la versione di Debian Testing).
Categorie: Forum Debianizzati

Re: Stampante HP Laserjet Pro MFP M130nw - "sfondo grigio"

Dom, 17/12/2017 - 11:26
@starkdeb:
Se possibile, sarebbe utile fornire un file di esempio che, riprodotto sulla Tua stampante, genera il comportamento che hai riferito.

Inoltre, sarebbe utile sapere come configuri la stampante, cioè se la configuri dall'interfaccia web di CUPS oppure dall'interfaccia dell'ambiente grafico che hai installato (in tal caso, quale e se puoi fornire gli screen-shot della configurazione).

Stante l'analisi di primo livello del log che hai inviato (che non mostra particolari anomalie), volendo ipotizzare una causa (escludendo che il documento originale sia la causa), quanto riferito potrebbe essere conseguente alla presenza nella configurazione della stampante di una opzione relativa alla gestione del colore (hai attivato la stampa a colori o stampi a colori dal programma con cui stampi ?), per cui nel rendering del documento (conversione dal formato utilizzato dal programma che stampa, a PDF - internamente a CUPS - e da PDF al linguaggio di stampa utilizzato dalla stampante) il colore chiaro del fondo del documento è rappresentato con un qualche livello di grigio; per una analisi più approfondita, vedi https://wiki.debian.org/DissectingandDebuggingtheCUPSPrintingSystem).

Per fornire ulteriori elementi, se possibile, impartisci i seguenti ulteriori comandi come utente root dopo aver acceso la stampante:
script log.txt

# aumenta il livello di log
cupsctl LogLevel=debug2
systemctl restart cups

# verifica stampante predefinita
lpstat -d

# invia e stampa una pagina di test
lp /usr/share/cups/data/default-testpage.pdf

# disabilita la stampante di dafault
cupsdisable $(lpstat -d | cut -d':' -f2)

# invia una pagina di test in stampa
lp /usr/share/cups/data/default-testpage.pdf

# visualizza la coda di stampa e copia i file in coda di stampa
lpq
ls /var/spool/cups -la
file /var/spool/cups/d*
cp /var/spool/cups/d* ~/

# riabilita la stampante (stampa la pagina di test)
cupsenable $(lpstat -d | cut -d':' -f2)

# riabilita la stampante di dafault (dovrebbe stampare la pagina di test)
cat /var/log/cups/error_log

# abbassa il livello di dettaglio dei log
cupsctl --no-debug-logging

exit

Quindi, invia il file log.txt ed i file d* che si trovano nella home dalla utenza di root.

Inoltre, potresti indicare se le pagine di test stampate sono affette dallo "sfondo grigio" ?

Inoltre, il file /etc/cups/ppd/HP_LaserJet_MFP_M129-M134.ppd sembrerebbe non essere nei repository Debian: da dove lo hai preso ? Puoi inviare questo file ?
Categorie: Forum Debianizzati

Re: Stampante HP Laserjet Pro MFP M130nw - "sfondo grigio"

Sab, 16/12/2017 - 23:45
Impartisci i comandi:
script log.txt
hp-check -t
exit

Quindi, invia il file log.txt
Categorie: Forum Debianizzati

Re: Stampante HP Laserjet Pro MFP M130nw - "sfondo grigio"

Sab, 16/12/2017 - 22:16
Aki ha scritto:Suggerirei a starkdeb di fornire maggiori dati in merito alla installazione di Debian a cui fa riferimento, alla sua disponibilità immediata per le verifiche del caso ed una dettagliata descrizione delle modalità di installazione di cups, hplip e di quanto ha installato e configurato.

Purtroppo domattina devo ripartire, abito a quasi quattrocento km da dove scrivo ora... inutile che vi faccia perdere altro tempo, speravo che potesse trattarsi di qualche inconveniente abbastanza comune e poter risolvere rapidamente. Per dovere di cronaca hplip e cups sono stati installati tramite synaptic, la distro è una 9.3, stampante collegata via usb... non saprei cosa altro dire...













ho semplicemente aggiunto la stampante scegliendo da questo elenco, può essere che il driver (se di driver si tratta...) sia troppo "generico" cioè fa riferimento a stampanti dal modello 129 al modello 134?
Categorie: Forum Debianizzati

Re: Trovare il maggiore tra N numeri in C

Sab, 16/12/2017 - 19:56
Certo: puoi consultare il seguente link.
Categorie: Forum Debianizzati

Re: Trovare il maggiore tra N numeri in C

Sab, 16/12/2017 - 17:22
Potresti farmi un esempio con del codice, o almeno con un algoritmo ?
Categorie: Forum Debianizzati

Re: Vorrei aggiungere un Hard Disk, ce la farà l'alimentator

Sab, 16/12/2017 - 16:41
In teoria ci dovresti stare (poi dipende cosa è attaccato a cosa). Diciamo che CPU più scheda video sono circa 150W a piena potenza. La scheda madre (non ho idea di quale sia) la stimiamo sui 30W.
Ora il problema non è quanto il consumo totale ma quello specifico per uscita (e dipende anche dal cablaggio) e da quanto cinese è l'alimentatore.
Categorie: Forum Debianizzati

Vorrei aggiungere un Hard Disk, ce la farà l'alimentatore?

Sab, 16/12/2017 - 16:04
Salve a tutti,
ho acquistato un disco Firecuda della Seagate da 2TB per dare un po' di sprint al mio PC.

Ora ho un dubbio che sicuramente voi potrete aiutarmi a risolvere: l'alimentatore del mio computer è dimensionato in maniera corretta per supportare anche questo nuovo disco?

Il mio sistema desktop è caratterizzato principalmente dal seguente hardware:
  • Intel Pentium Dual-Core E5300
  • AMD Radeon HD 5770
  • disco Sata 3.5"
  • disco Sata 2.5"
  • lettore/masterizzatore CD/DVD

Il nuovo hard disk della Seagate ha un assorbimento tipico da 6.7 W

Questo è l'URL della targhetta del mio alimentatore da 500 W:
http://i63.tinypic.com/jglaqf.jpg

Grazie anticipate a chi mi darà una mano
Categorie: Forum Debianizzati

Re: ionice e pipe

Sab, 16/12/2017 - 14:18
Avendo il file test.sh:
#! /bin/bash
gzip -c /dev/urandom | gzip -d | dd of=/dev/null bs=1M

puoi impartire il seguente comando:
ionice -c 2 -n 7 ./test.sh &
[1] 4178

Per verificare:
$ ps l
F   UID   PID  PPID PRI  NI    VSZ   RSS WCHAN  STAT TTY        TIME COMMAND
0  1000  4141  4139  20   0  25020  6852 -      Ss   pts/2      0:00 /bin/bash
0  1000  4178  4141  20   0  13248  2964 -      S    pts/2      0:00 /bin/bash ./test.sh
0  1000  4179  4178  20   0   4492  1444 -      R    pts/2      0:02 gzip -c /dev/urandom
0  1000  4180  4178  20   0   4492   716 -      S    pts/2      0:00 gzip -d
0  1000  4181  4178  20   0   7108  1744 -      S    pts/2      0:00 dd of=/dev/null bs=1M
0  1000  4183  4141  20   0  10688  2100 -      R+   pts/2      0:00 ps l

$ ionice -p 4179
best-effort: prio 7

In alternativa, puoi impartire il seguente comando:
$ ionice -c 2 -n 7 /bin/bash -c "gzip -c /dev/urandom | gzip -d | dd of=/dev/null bs=1M" &
[1] 4301

$ ps l
F   UID   PID  PPID PRI  NI    VSZ   RSS WCHAN  STAT TTY        TIME COMMAND
0  1000  4141  4139  20   0  25036  7092 -      Ss   pts/2      0:00 /bin/bash
0  1000  4301  4141  20   0  13244  2932 -      S    pts/2      0:00 /bin/bash -c gzip -c /dev/urandom | gzip -d | dd of=/dev/null bs=1M
0  1000  4302  4301  20   0   4492  1408 -      R    pts/2      0:02 gzip -c /dev/urandom
0  1000  4303  4301  20   0   4492   724 -      S    pts/2      0:00 gzip -d
0  1000  4304  4301  20   0   7108  1792 -      S    pts/2      0:00 dd of=/dev/null bs=1M
0  1000  4305  4141  20   0  10688  2152 -      R+   pts/2      0:00 ps l

$ ionice -p 4302
best-effort: prio 7
Categorie: Forum Debianizzati

Re: [RISOLTO] XZ-compressed data is corrupt

Sab, 16/12/2017 - 14:14
ops, link postato di fretta, grazie per la segnalazione
Categorie: Forum Debianizzati