Forum Debianizzati

Condividi contenuti
Aggiornato: 22 min 45 sec fa

Nota su shell dash

Gio, 02/11/2017 - 10:51
Ciao a tutti, scrivo solo per condividere una curiosità.
Non mi sono mai messo a studiare le differenze tra la shell bash a la dash.

Oggi ho preparato un piccolo script per controllare con quale ip sto uscendo (ho 2 linee in ufficio).
Se non esco dalla linea "giusta", faccio stampare un avviso:

#!/bin/dash
ip_current="$(dig +short @resolver1.opendns.com myip.opendns.com)"
ip_provider_x="1.2.3.4"

[ "$ip_current" == "$ip_provider_x" ] || wall "Provider X is down!"


Con mia sorpresa, viene stampato un messaggio di errore:
/usr/local/bin/check_active_network.sh: 6: [: 62.94.229.113: unexpected operator

Le possibilità sono 2: l'operatore == non è usato in dash, oppure gli ip vengono interpretati come numeri anziché come stringhe.

Cerco un po' di documentazione.
Faccio il giro da wikipedia per trovare il sito ufficiale che è composto da una singola pagina, modifica l'ultima volta nel 2011, con zero documentazione.
Correggetemi se sbaglio, ma il man sembra essere l'unica fonte ufficiale di informazioni.

Nel man leggo
Enclosing characters within double quotes preserves the literal meaning of all characters except dollarsign ($), backquote (`), and backslash (\).

Quindi propendo a pensare che '==' non sia usato in dash come operatore di confronto.
Continuo la lettura del man...

Nella sezione "Flow-Control Constructs -- if, while, for, case" non parlano di operatori di confronto.
Finalmente trovo la risposta nella sezione
[ expression ]
            s1 = s2       True if the strings s1 and s2 are identical.
            s1 != s2      True if the strings s1 and s2 are not identical.
Categorie: Forum Debianizzati

mi serve uno script per occupare la cpu al 90%

Gio, 02/11/2017 - 03:35
devo fare delle prove impostando le priorita' ai processi e mi servirebbe un processo che non consumi la cpu al 100% ma al 90%
ho fatto vari script ma tutti vanno al 100%

avete qualche idea?
Categorie: Forum Debianizzati

Re: Guide su driver AMD - cambio titolo

Gio, 02/11/2017 - 01:34
@Spoon
con me non ti devi assolutamente scusare, sono la peggio di tutti quando c'è da mettere mano a "cose non mie". I tuoi dubbi sono stati (alcuni lo sono ancora) i miei e non ho perso tempo.

@s3v
ho visto la nuova guida sullo spostamento. Giusto perché capisco sempre fischi per fiaschi, segnalo questo trafiletto:
Tuttavia la nuova pagina non conterrà la storia delle modifiche precedenti allo spostamento e questo rende molto più difficile controllare le modifiche.
Se si intende la cronologia, nelle guide spostate in cui sono incappata, risulta esportata correttamente. Sia la guida di Firefox che quella modificata da Spoon ce l'hanno.
Categorie: Forum Debianizzati

Re: Samsung M2070 errore di comunicazione con lo scanner

Mer, 01/11/2017 - 22:59
ciao,
il cavo è quello originale della stampante. Il dell ha soltanto le porte usb 2.0, sul desktop le ho provate tute e attualmente uso la 2.0 che ha sempre funzionato con le precedenti distribuzioni sia con la vecchia stampante samsung scx3260 sia con l'attuale stampante M2070.
L'unico dubbio che mi è rimasto è quello di aver installato la stampante sul desktop come root perché quando ho installato debian non ho aggiunto i privilegi di amministratore all'utente principale. Ho disinstallato tutti i driver della stampante, ho riprovato ma non funziona ugualmente.
saluti
Categorie: Forum Debianizzati

Mapillary computer vision

Mer, 01/11/2017 - 20:52
Opportunità per un lavoro da casa, lo offre Mapillary per lavorare nel computer vision team.
http://jobs.mapillary.com/o/computer-vision-intern
Categorie: Forum Debianizzati

Re: Samsung M2070 errore di comunicazione con lo scanner

Mer, 01/11/2017 - 20:21
sul Desktop hai usato lo stesso cavo che hai usato con il Dell?
Con il Dell che porta hai usato? USB 2 o 3?
Categorie: Forum Debianizzati

Re: Guide su driver AMD - cambio titolo

Mer, 01/11/2017 - 18:36
Grazie a entrambi
Effettivamente era tutto scritto nel wiki, ammetto di non aver cercato troppo a lungo, chiedo scusa per aver abusato del vostro tempo Ho spostato la pagina e controllato per sicurezza seguendo qualche link, il redirect è a posto. Credo che farò la stessa operazione anche per la guida sui driver proprietari, poi potrei aggiornare a mano i link a quelle pagine per fare un po' di "pulizia". Ci sono link che partono da pagine di altri utenti quindi non sarà possibile eliminare la pagina di redirect, ma perlomeno i link dalle altre pagine condivise riporteranno il nome corretto.

Grazie ancora
Categorie: Forum Debianizzati

Re: postfix smtpd restrictions

Mer, 01/11/2017 - 18:09
risolto?
Categorie: Forum Debianizzati

Samsung M2070 errore di comunicazione con lo scanner

Mer, 01/11/2017 - 16:44
Buongiorno a tutto il gruppo è la prima volta che scrivo su debianizzati e vorrei esporre questo strano problema.
Ho installato la stampante Samsung multifunzione M2070 su un portatile Dell Inspiron con installato Debian 9 stable e tutto funziona alla perfezione sia stampante che scanner usb.
La procedura che ho eseguito è la seguente: ho installato cups; poi i driver della stampante che ho scaricato dal sito ufficiale Samsung e installati con sh install.sh; con i comandi sane.find.scanner e scanimage -L lo scanner viene rilevato; poi con lsusb ho rilevato il codice produttore e prodotto che ho inserito nel file xerox_mfp.conf. Tutto funziona senza problemi.
Ho seguito la stessa procedura per installare la stampante sul computer desktop Asus, sistema operativo Debian 9 stable ma lo scanner, anche se rilevato con i comandi di cui sopra, non funziona né con simple-scan né con Xsane. Al momento della scansione restituisce la seguente stringa “errore di comunicazione con lo scanner” e la stampante si riavvia.
Non sono riuscito a trovare una soluzione, ho provato sia con le porte USB 2.0 e Usb 3.0 ma l’errore è sempre lo stesso. Qualcuno ha idea da cosa può dipendere questo errore? Attendo suggerimenti grazie
Domenico
Categorie: Forum Debianizzati

Re: postfix smtpd restrictions

Mer, 01/11/2017 - 15:50
Mi rispondo da solo,
parlando con sviluppatori postfix su #postfix irc, la variabile $mynetworks= resta vuota e l'opzione permit_mynetworks deprecated !


buona giornata !
Categorie: Forum Debianizzati

connessione da cell come router-wifi

Mer, 01/11/2017 - 15:01
Ho in corso un guasto con Vodafone, che mi ha offerto 15GB di navigazione
dal cellulare usato come Router-wifi. Ora, da Windows (...) e da LinuxMint
la connessione funziona devo ammettere bene, e buona velocità. Da Debian
invece la connessione apparentemente ha luogo, ma po non navigo affatto.
Nemmeno il più banale ping a http://www.google.it. Da cosa può dipendere?

grazie
m
Categorie: Forum Debianizzati

Re: Velocità hub USB 3.0 collegato a PC con USB 2.0

Mer, 01/11/2017 - 14:29
marcomg ha scritto:Andrà alla metà della velocità di un usb 2 se non peggio.

Come sospettavo...

marcomg ha scritto:Ma basta provare no?

Al momento non sono munito di un hub USB 3.0 altrimenti non avrei chiesto

Grazie per la risposta
Categorie: Forum Debianizzati

Re: FTP server: dall'installazione al deploy, la guida.

Mer, 01/11/2017 - 13:25
Buongiorno a tutti, ragazzi!
Torno a farmi sentire dopo un po', scusandomene anche, perché volevo dirvi che il server FTP relativo a questo progetto è tornato online dopo un paio di mesi di shutdown forzato (a causa di forza maggiore) mi scuso in anticipo se non ho avvisato qui del relativo shutdown del server, ma, purtroppo, ho avuto pochissimo tempo a disposizione, in questi mesi.
Adesso, che ho, relativamente, più calma, ho rebootato il server e spero, quanto prima, di riuscire a dargli una sistemazione definitiva, in modo da non doverlo più spegnere, fino ad allora, il server sarà online non oltre la mezzanotte di ogni giorno.
A presto!

Irmin
Categorie: Forum Debianizzati

Re: Velocità hub USB 3.0 collegato a PC con USB 2.0

Mer, 01/11/2017 - 12:51
Andrà alla metà della velocità di un usb 2 se non peggio. Ma basta provare no?
Categorie: Forum Debianizzati

Velocità hub USB 3.0 collegato a PC con USB 2.0

Mer, 01/11/2017 - 12:15
Ho un PC con porte USB 2.0.
Ipotizziamo che io abbia 2 chiavette USB 3.0 e voglia trasferire i miei dati dalla prima alla seconda.
Ora, se inserissi entrambe le chiavette ad un hub USB 3.0 collegato al mio PC (con USB 2.0), che velocità di trasferimento dati avrei tra le due pen drive? Ovvero, avrei un transfer rate paragonabile a quello di una USB 2.0 o 3.0?

Spero di essere stato chiaro.

Un saluto a tutti
Categorie: Forum Debianizzati

Re: Guide su driver AMD - cambio titolo

Mer, 01/11/2017 - 11:23
Spoon ha scritto:Ciao a tutti
ho notato che le due guide sui driver per schede AMD necessitavano di lavoro e mi sono messo all'opera. Ho appena finito di aggiornare la guida "Driver ATI Radeon Open" (http://guide.debianizzati.org/index.php ... adeon_Open), passerò poi a quella sui driver proprietari che ho per il momento adottato.
Ottimo lavoro
Spoon ha scritto:Tuttavia, mi pare che il titolo della guida sui driver liberi non sia più appropriato: con gli ultimi aggiornamenti i driver open non sono solo i Radeon, ma anche il driver AMDGPU.
Esatto, il titolo andrebbe cambiato.
Spoon ha scritto:Ad ogni modo, non ho trovato il modo per modificare il titolo della pagina. Mi è venuto il dubbio che possa essere impossibile, per evitare di rompere dei link che puntano ad essa. Sapete un modo per modificarlo? O sapete suggerirmi un modo alternativo per usare un nuovo titolo? Mi piacerebbe usare "Driver AMD liberi".
Integro l'esauriente risposta di Selky aggiungendo che, quando si modifica il titolo di una pagina (cioè si "sposta" una pagina), viene automaticamente creato un redirect che evita che possano crearsi dei broken link. In pratica le pagine con link che puntano al vecchio titolo punteranno al redirect che a sua volta punta alla pagina con il nuovo titolo.
Quindi non esiste pericolo di combinare disastri
Ora che leggo la pagina d'aiuto mi accorgo che forse andrebbe specificato meglio il tutto, il "pericolo broken link" dovrebbe attanagliare solo chi cancella una pagina o un redirect.
Selky ha scritto:Ciao Spoon
ci sono passata pure io, addirittura la prima volta fu una tragedia, risolto con la pazienza di s3v che mi sopportava...
La prima volta che spostai una pagina del Wiki (oltre a non sapere bene quello che stavo facendo) ebbi secondi di paura vera.
Momenti che restano impressi
Categorie: Forum Debianizzati

Re: [RISOLTO] systemd - swap

Mar, 31/10/2017 - 23:43
mark ha scritto:ecco cosa dice systemd
systemctl mask dev-sda8.swap
Created symlink from /etc/systemd/system/dev-sda8.swap to /dev/null.

il file di unit dev-sda8.swap non dovrebbe essere - se generato dinamicamente da systemd a partire da /etc/fstab - in /etc/ e per questo motivo che le variazione in /etc/fstab non sono propagate e hai dovuto - di fatto - eliminare /etc/systemd/system/dev-sda8.swap

il file di unit dev-sda8.swap - se dinamico - dovrebbe essere creato in /run/systemd/generators (vedi http://sources.debian.net/src/systemd/232-25%2Bdeb9u1/src/core/manager.c/?hl=3007#L2996 e http://sources.debian.net/src/systemd/232-25%2Bdeb9u1/src/shared/path-lookup.c/?hl=818#L818)
Categorie: Forum Debianizzati

Iptables Transmission

Mar, 31/10/2017 - 23:19
Buonasera a tutti , mi chiamo Daniele e mi sono appena iscritto al forum.
Utilizzo Debian da circa 2 anni, e sono molto soddisfatto di questo sistema operativo.
La versione che sto utilizzando ora è Debian 8 jessie.
Ultimamente mi sono trovato difronte ad un problema relativo ad Iptables , e nello specifico nel configurare una regola adeguata per Transmission.
Trasmission ha sermpre funzionato alla grande , il router vedeva le porta 51413 ( default ) , sia TCP che UDP aperta , tramite Upnp, ma da quando ho inserito la regola di INPUT " drop all " non riesco ne ad accedere alla pagina web di Transmission alla porta 9091, ed il ruoter nel menù Upnp non dà nessuno stato delle porte.
Se rimuovo la regola tutto ritorna perfettamente funzionante.
Avrei bisogno di un consiglio/aiuto da qualcuno per poter configuare una regola adeguata, volendo comunque mantenere come regola "finale" il DROP all ipv4 in INPUT.
Ogni consiglio sarebbe molto utile, ringrazio tutti e buona serata !!.
Categorie: Forum Debianizzati

Re: Ripristino menù contesuale in lxqt

Mar, 31/10/2017 - 17:59
Non ho pcmanfm sottomano, vado a memoria. Fra le opzioni dovresti trovare le impostazioni del desktop e una voce, con una spunta, che se abilitata imposta il menu di openbox come predefinito.

EDIT: FAQ di lxde, dovrebbe fare al caso tuo:
https://wiki.lxde.org/en/LXDE:Questions#Right_click_on_the_desktop_renders_a_weird_menu_.28aka_where_did_my_desktop_icons_go.3F.29
Categorie: Forum Debianizzati

Re: Guide su driver AMD - cambio titolo

Mar, 31/10/2017 - 17:53
Ciao Spoon

Per rinominare una pagina, una volta effettuato l'accesso nel menu in alto a destra (quello relativo a modifica, cronologia, ecc), alla sinistra della casella della ricerca trovi un icona con freccia rivolta in basso "sposta".
Selezionandola si apre un'ulteriore finestra dove puoi effettuare il cambio titolo.

Sicuramente lo trovi spiegato meglio qua: http://guide.debianizzati.org/index.php ... una_pagina

P.S.
ci sono passata pure io, addirittura la prima volta fu una tragedia, risolto con la pazienza di s3v che mi sopportava...
Categorie: Forum Debianizzati