Forum Debianizzati

Condividi contenuti
Aggiornato: 1 ora 8 min fa

Re: Scomparse note adesive!!

Lun, 06/08/2018 - 22:14
non saprei cosa suggerirti, nel frattempo hai continuato a usare quella partizione/disco? se la risposta è si, diventa sempre più improbabile riuscire a recuperare qualcosa
Categorie: Forum Debianizzati

Re: Link simbolico tra due file

Lun, 06/08/2018 - 22:01
dal wiki di debian qualche suggerimento
https://wiki.debian.org/resolv.conf
Categorie: Forum Debianizzati

Link simbolico tra due file

Lun, 06/08/2018 - 21:44
Salve ragazzi, dovrei modificare il file /etc/resolv.conf inserendo dei DNS, ma purtroppo questo file è collegato con /var/run/NetworkManager/resolv.conf con un collegamento simbolico che però non riesco ad eliminare neanche forzandolo. Voi sapete come faccio ad eliminare il link tra questi due file? Ho cercato in molte guide ma non funziona niente.
Per intenderci...ho provato anche eliminando il file di origine, ma riavviando il network-manager ricompaiono i due file con il collegamento simbolico fra i due.
Categorie: Forum Debianizzati

Re: [CHIUSO]Scomparse note adesive!!

Lun, 06/08/2018 - 21:30
@mark e @marcomg È vero è un po' difficile recuperarlo, se non impossible, perchè sicuramente il file è stato sostituito dal file "stickynotes-applet.xml" stesso.
In windows c'è una procedura che ti permette di recuperare le versioni precedenti di un file dalle proprietà. Per caso si può fare anche su linux? Non mi arrendo facilmente AHAHAHAH
Comunque....qui ci chiamiamo tutti marco? XDXD
Categorie: Forum Debianizzati

Videocam: i driver vanno e vengono

Lun, 06/08/2018 - 19:00
Ho una vecchia videocam USB2, e nella macchina prese USB2 e USB3.
Poiché il dato di fatto è che nel lato posteriore ho solo USB3,
avevo usato una di quelle prese per la videocam. Ora, l'aspetto strano
è che la videocam ha sempre funzionato, per quel poco che la uso
e dunque non ho uno spettro ampio di casi (passano settimane e settimane
senza che la usi). Da qualche giorno però quando carico il sistema ricevo
usb 3-3: cannot set freq 32000 to epx6
5:2 cannot get min/max values for control 2 (id 5)

e un'altra sfilza di avvisi simili che fanno durare minuti il caricamento
e allo stesso modo lo spegnimento. Spostando su una presa USB2 tutto va.
La cosa che mi resta oscura è perché per un lungo periodo tuttavia
anche utilizzando una USB3 non avevo problemi...

grazie
m
Categorie: Forum Debianizzati

Re: [Risolto] Installazione fallita per libglx-mesa0 et al.

Dom, 05/08/2018 - 20:17
Underpass ha scritto:Io ho idea che non abbiano intenzione di risolvere, dal momento che - da quel che capisco - tutte le distribuzioni più importanti funzionano in questo modo.
Già, pare anche a me che non abbiano intenzione di tornare indietro. Hanno inserito una nota nel file /usr/share/doc/util-linux/NEWS.Debian.gz:
util-linux (2.32-0.4) unstable; urgency=medium

The util-linux implementation of /bin/su is now used, replacing the
one previously supplied by src:shadow (shipped in login package), and
bringing Debian in line with other modern distributions. The two
implementations are very similar but have some minor differences (and
there might be more that was not yet noticed ofcourse), e.g.

- new 'su' (with no args, i.e. when preserving the environment) also
preserves PATH and IFS, while old su would always reset PATH and IFS
even in 'preserve environment' mode.
- su '' (empty user string) used to give root, but now returns an error.
- previously su only had one pam config, but now 'su -' is configured
separately in /etc/pam.d/su-l

The first difference is probably the most user visible one. Doing
plain 'su' is a really bad idea for many reasons, so using 'su -' is
strongly recommended to always get a newly set up environment similar
to a normal login. If you want to restore behaviour more similar to
the previous one you can add 'ALWAYS_SET_PATH yes' in /etc/login.defs.

Mi rammarico che abbiano documentato un cambiamento così importante in una nota di un file all'interno di un pacchetto a cui nessuno ricondurrebbe il problema.
Inoltre ci saranno parecchie guide del Wiki da aggiornare.

cuzzo ha scritto:per creare l'alias in .bashrc"
basta aggiungere
alias su='su -'

senza if o altro?
Non serve altro.
Il file .bashrc viene letto ogni volta che si avvia bash per cui, per rendere effettive le modifiche, basta chiudere e riaprire l'emulatore di terminale (se ti trovi in un ambiente grafico), eseguire "source ~/.bashrc" se ti trovi in una tty o effettuare un logout/login.
Ti consiglio di inserire una riga di commento in .bashrc che spiega il perché hai fatto quella modifica e, magari, contenente un rimando a questa discussione.
Tornerà utile quando questo ricordo abbandonerà la memoria
Categorie: Forum Debianizzati

Risparmio batteria

Dom, 05/08/2018 - 19:20
Salve,
vorrei fare uno script da avviare al boot per ottimizzare i consumi della batteria di un laptop con i seguenti comandi:

echo '1500' > '/proc/sys/vm/dirty_writeback_centisecs'
echo 'min_power' > '/sys/class/scsi_host/host0/link_power_management_policy'
echo 'min_power' > '/sys/class/scsi_host/host1/link_power_management_policy'
echo '1' > '/sys/module/snd_hda_intel/parameters/power_save'
echo '0' > '/proc/sys/kernel/nmi_watchdog'
echo 'auto' > '/sys/bus/i2c/devices/i2c-1/device/power/control'
echo 'auto' > '/sys/bus/i2c/devices/i2c-2/device/power/control'
echo 'auto' > '/sys/bus/usb/devices/1-1/power/control'
echo 'auto' > '/sys/bus/i2c/devices/i2c-3/device/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:00:1f.2/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:00:1f.3/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:00:00.0/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:00:14.2/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:00:02.0/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:00:14.0/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:00:1f.0/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:02:00.0/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:00:04.0/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:00:16.0/power/control'
echo 'auto' > '/sys/bus/pci/devices/0000:00:17.0/power/control'


Non so se la sintassi è giusta e come sarebbe meglio procedere, se usare rc.local o se muovermi diversamente.
Qualcuno potrebbe darmi qualche indicazione?

Saluti e grazie anticipatamente,
Categorie: Forum Debianizzati

Instalazione da chiavetta non va....

Dom, 05/08/2018 - 19:14
Ciao a tutti!
Ho l'intenzione di installare kali linux da chiavetta usb e ho svolto le seguenti operazioni
1) Da win10 ho scaricato "rufus3.1.exe" ed ho installato la iso kali linux regolarmente.
2) Ho riavviato il pc e ho eseguito normalmente la distribuzione in live
Adesso voglio installare il sistema operativo dalla usb su hard disk, ma quando scelgo install , riesco ad inserire la lingua , poi la tastiera , poi clicco avanti e ricevo il seguente messaggio di errore:
"Si e verificato un problema nel leggere i dati dal cd rom assicurarsi che il cd rom sia nell'unita..."
In sostanza ho capito che nella usb in qualche file c'e' scritto di prendere un dato file dal cd-rom . Che non contiene il disco di installazione.
Gradirei sape , in quale file e' contenuta l'istruzione di prelevare dal cd-rom i file di installazione. O magari un'altra soluzione.

Grazie
Categorie: Forum Debianizzati

Instalazione da chiavetta non va....

Dom, 05/08/2018 - 19:14
Ciao a tutti!
Ho l'intenzione di installare kali linux da chiavetta usb e ho svolto le seguenti operazioni
1) Da win10 ho scaricato "rufus3.1.exe" ed ho installato la iso kali linux regolarmente.
2) Ho riavviato il pc e ho eseguito normalmente la distribuzione in live
Adesso voglio installare il sistema operativo dalla usb su hard disk, ma quando scelgo install , riesco ad inserire la lingua , poi la tastiera , poi clicco avanti e ricevo il seguente messaggio di errore:
"Si e verificato un problema nel leggere i dati dal cd rom assicurarsi che il cd rom sia nell'unita..."
In sostanza ho capito che nella usb in qualche file c'e' scritto di prendere un dato file dal cd-rom . Che non contiene il disco di installazione.
Gradirei sape , in quale file e' contenuta l'istruzione di prelevare dal cd-rom i file di installazione. O magari un'altra soluzione.

Grazie
Categorie: Forum Debianizzati

Firefox-esr no supporto h264

Dom, 05/08/2018 - 17:01
uso una debian sid e come browser vorrei usare firefox-esr al posto della versione "normale" di firefox. Però, mentre in firefox 61.0.1 l'html5 funziona perfettamente, nella versione esr manca il supporto per i video in h264. Ho provato a fare una ricerca , ma non ho trovato nulla a riguardo. Qualcuno sa come abilitare quei codec?
Categorie: Forum Debianizzati

Re: [Risolto] Installazione fallita per libglx-mesa0 et al.

Dom, 05/08/2018 - 15:40
anche gdebi non va( testing ) per questo e provando da terminale mi dice la stessa cosa
dpkg: attenzione: "ldconfig" non è stato trovato in PATH o non è un eseguibile
dpkg: attenzione: "start-stop-daemon" non è stato trovato in PATH o non è un eseguibile
dpkg: errore: 2 programmi attesi non sono stati trovati in PATH o non sono eseguibili
Nota: la variabile PATH di root dovrebbe contenere /usr/local/sbin, /usr/sbin e /sbin

e con su - va.

per creare l'alias in .bashrc"
basta aggiungere
alias su='su -'

senza if o altro?

grazie e gnao dal cuzzo
Categorie: Forum Debianizzati

Re: [Risolto] Installazione fallita per libglx-mesa0 et al.

Dom, 05/08/2018 - 01:19
Io ho idea che non abbiano intenzione di risolvere, dal momento che - da quel che capisco - tutte le distribuzioni più importanti funzionano in questo modo.

Per tamponare si può aggiungere al file /etc/login.defs la riga

ALWAYS_SET_PATH        yes


che dovrebbe ripristinare il vecchio comportamento.
Categorie: Forum Debianizzati

Re: Installazione fallita per libglx-mesa0 et al.

Sab, 04/08/2018 - 22:51
Jinko ha scritto:Rubo alcuni link da linuxmint e ubuntu

https://unix.stackexchange.com/question ... h-variable
https://ubuntuforums.org/showthread.php?t=1942520
https://forums.linuxmint.com/viewtopic.php?t=98706
Grazie Jinko, purtroppo non sono serviti a capire il problema

È servito però questo:
https://bugs.debian.org/cgi-bin/bugrepo ... bug=904988
da cui si evince che per ottenere i permessi di root è necessario un
$ su -

anziché:
$ su

che ho utilizzato dal primo giorno di Linux.
Con "su -" funziona tutto:
# echo $PATH
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin

Vabbé, mi sono creato un alias nel file ".bashrc":
alias su='su -'



Continuerò a tener d'occhio quel bug report per vedere se risolvono.
Categorie: Forum Debianizzati

Re: Il sistema operativo UNIX descritto da Kernighan e Ritch

Sab, 04/08/2018 - 22:25
Grazie per la condivisione.
Categorie: Forum Debianizzati

Re: mate+ATI, da colori a scala di grigi

Sab, 04/08/2018 - 22:18
Onestamente non sono molto preparato su MATE , pero forse questo articolo e commando potrebbero aiutarti

https://askubuntu.com/questions/102440/ ... lor-scheme
http://xcalib.sourceforge.net/
Categorie: Forum Debianizzati

[Risolto] Installazione fallita per libglx-mesa0 et al.

Sab, 04/08/2018 - 22:17
Salve.

L'aggiornamento odierno fallisce:
# apt upgrade
[...]
I seguenti pacchetti saranno aggiornati:
  libegl-mesa0 libegl1-mesa libgbm1 libgl1-mesa-dev libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa
  libgles2-mesa libglx-mesa0 mesa-common-dev mesa-vdpau-drivers
11 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
È necessario scaricare 9.500 kB di archivi.
Dopo quest'operazione, verranno liberati 874 kB di spazio su disco.
Continuare? [S/n]  s
[...]
dpkg: attenzione: "ldconfig" non è stato trovato in PATH o non è un eseguibile
dpkg: attenzione: "start-stop-daemon" non è stato trovato in PATH o non è un eseguibile
dpkg: errore: 2 programmi attesi non sono stati trovati in PATH o non sono eseguibili
Nota: la variabile PATH di root dovrebbe contenere /usr/local/sbin, /usr/sbin e /sbin
E: Sub-process /usr/bin/dpkg returned an error code (2)


# echo $PATH
/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games

# whereis ldconfig
ldconfig: /sbin/ldconfig /usr/share/man/man8/ldconfig.8.gz

# whereis start-stop-daemon
start-stop-daemon: /sbin/start-stop-daemon /usr/share/man/man8/start-stop-daemon.8.gz

A quanto ho potuto capire il problema risiede nel fatto che "/sbin" non si trova nel PATH, ma questa variabile d'ambiente non è mai stata cambiata da me (non volontariamente almeno...).
A voi il PATH è diverso? Potrei aggiungere quel percorso a mano ma non vorrei fare modifiche senza capire se è un problema di qualche pacchetto o solo mio.

Utilizzo Debian testing.

Grazie.
Categorie: Forum Debianizzati

Re: Impossibile cliccare su icone

Sab, 04/08/2018 - 22:11
Purtroppo non possiamo fornire una risposta con le informazioni fornite,
Categorie: Forum Debianizzati

Re: PureOS approvato da FSF

Sab, 04/08/2018 - 22:10
grazie per la notifica,
Categorie: Forum Debianizzati