Forum Debianizzati

Condividi contenuti
Aggiornato: 5 min 17 sec fa

Re: [RISOLTO] ripristino rc.local in Debian Strech

Mar, 24/07/2018 - 15:21
si, ho compreso la causa del malfunzionamento.
La directory rc.local non è configurata in default in Debian Strech, ma è possibile aggiungerla e renderla operativa seguendo le istruzioni che ho riportato.
Non so il motivo per cui non era abilitata di default, ma è possibile con la guida che ho postato.
Avevo provato a rendere operativo lo script da /etc/init.d, purtoppo non ci sono riuscito.
Forse anche la dire directory "init.d" necessiti la configurazione dei permessi, ma risolsi l'avvio automatico con rc.local e non ho approfondito la questione per "init.d"
Categorie: Forum Debianizzati

Re: [RISOLTO] ripristino rc.local in Debian Strech

Mar, 24/07/2018 - 12:30
Al di là delle istruzioni, hai compreso la causa del malfunzionamento ed in che modo le istruzioni hanno permesso di superarlo ?
Categorie: Forum Debianizzati

Re: Raspberry pi e fastweb

Mar, 24/07/2018 - 12:03
Ok, ma il problema è che il pi non pinga neppure. Ci acced via ssh da locale e se lancio il ping, la richiesta va in scadenza
Categorie: Forum Debianizzati

Re: avvio automatico script.sh

Mar, 24/07/2018 - 11:18
Ci sono riuscito !
Spiego come ho fatto: ho seguito questa guida e gli script riportati sono funzionanti al riavvio del sistema:
https://blog.smsoft.it/2017/10/03/debia ... -rc-local/

Scusate, e grazie di tutto

Riporto la soluzione affinchè tutti possano leggere velocemente il ripristino di rc.local in Debian Strech.

nano /etc/rc.local

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

exit 0

Salvare il documento e successivamente dare i permessi di esecuzione della directory:

chmod +x /etc/rc.local
systemctl start rc-local
systemctl status rc-local
Categorie: Forum Debianizzati

Re: debian ssd e trim

Mar, 24/07/2018 - 11:13
Aki ha scritto:Selky ha scritto:Quesito Risolto
Grazie Selky per averci aggiornato al posto del richiedente utente pota. Contrassegno la discussione come risolta.

chiedo scusa..mi è proprio sfuggito.grazie
Categorie: Forum Debianizzati

Re: Installazione stampante HP Officejet J3680

Mar, 24/07/2018 - 11:00
Installer log saved in: hplip-install_Tue-24-Jul-2018_10:58:28.log

\error: You are running the installer as root. It is highly recommended that you run the installer as
error: a regular (non-root) user. Do you still wish to continue?
Continue with installation (y=yes, n=no*, q=quit) ? y

note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.
error: debian-9.5 version is not supported, so all dependencies may not be installed. However trying to install using debian-9.4 version packages.

Press 'y' to continue auto installation. Press 'n' to quit auto instalation(y=yes, n=no*): y


INSTALLATION MODE
-----------------
Automatic mode will install the full HPLIP solution with the most common options.
Custom mode allows you to choose installation options to fit specific requirements.

Please choose the installation mode (a=automatic*, c=custom, q=quit) : a


INTRODUCTION
------------
This installer will install HPLIP version 3.18.6 on your computer.
Please close any running package management systems now (YaST, Adept, Synaptic, Up2date, etc).


DISTRO/OS CONFIRMATION
----------------------
Distro appears to be Debian 9.5.

Is "Debian 9.5" your correct distro/OS and version (y=yes*, n=no, q=quit) ? y

Initializing. Please wait...


INSTALLATION NOTES
------------------
NOTE: Disable the CD Sources in your apt sources.list or the install will fail and hang.

Please read the installation notes. Press <enter> to continue or 'q' to quit:


SECURITY PACKAGES
-----------------
AppArmor is installed.
AppArmor protects the application from external intrusion attempts making the application secure

Would you like to have this installer install the hplip specific policy/profile (y=yes*, n=no, q=quit) ? y


RUNNING PRE-INSTALL COMMANDS
----------------------------
OK


MISSING DEPENDENCIES
--------------------
Following dependencies are not installed. HPLIP will not work if all REQUIRED dependencies are not installed and some of the HPLIP features will not work if OPTIONAL dependencies are not installed.
Package-Name Component Required/Optional
pyqt5-dbus gui_qt5 REQUIRED
pyqt5 gui_qt5 REQUIRED
Do you want to install these missing dependencies (y=yes*, n=no, q=quit) ? y


INSTALL MISSING REQUIRED DEPENDENCIES
-------------------------------------
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency: pyqt5-dbus (PyQt 5 DBus - DBus Support for PyQt5)
warning: Missing REQUIRED dependency: pyqt5 (PyQt 5- Qt interface for Python (for Qt version 4.x))


CHECKING FOR NETWORK CONNECTION
-------------------------------
Network connection present.


RUNNING PRE-PACKAGE COMMANDS
----------------------------
su -c "dpkg --configure -a" (Pre-depend step 1)
su -c "apt-get install -f" (Pre-depend step 2)
su -c "apt-get update" (Pre-depend step 3)
OK


DEPENDENCY AND CONFLICT RESOLUTION
----------------------------------
Running 'su -c "apt-get install --force-yes -y python-dbus.mainloop.pyqt5"'
Please wait, this may take several minutes...
Running 'su -c "apt-get install --force-yes -y gtk2-engines-pixbuf"'
Please wait, this may take several minutes...
Running 'su -c "apt-get install --force-yes -y python-pyqt5"'
Please wait, this may take several minutes...
error: A required dependency 'pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)' is still missing.
error: A required dependency 'pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))' is still missing.


RUNNING POST-PACKAGE COMMANDS
-----------------------------
OK


RE-CHECKING DEPENDENCIES
------------------------
error: A required dependency 'pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)' is still missing.
error: A required dependency 'pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))' is still missing.
error: Installation cannot continue without these dependencies.
error: Please manually install this dependency and re-run this installer.
Categorie: Forum Debianizzati

Re: Scheda di rete INTEL I219-V non riconosciuta

Mar, 24/07/2018 - 10:40
Ciao s3v dopo una ricerca su google sono andato un pò avanti e ho risolto così :
ho letto che var/cache/apt/archives/partial/ aveva solo i permessi di root e non di _apt quindi li ho modificati in questo modo :

 
chown -Rv _apt:root /var/cache/apt/archives/partial/
chmod -Rv 700 /var/cache/apt/archives/partial/


bene ma si generava ancora un altro errore :

/bin/sh: 1: /usr/bin/apt-listchanges: not found
E: Il sottoprocesso /usr/bin/apt-listchanges --apt || test $? -lt 10 ha restituito un codice d'errore (1)
E: Failure running script /usr/bin/apt-listchanges --apt || test $? -lt 10
Installazione di un pacchetto non riuscita. Tentativo di ripristino:

e ho notato che mancava il file apt-listchanges.
Quindi ho copiato il file da una macchina funzionante in /usr/bin.
Ho cambiato i permessi del file

chmod 755 /usr/bin/apt-listchanges


ed infine ho pulito con:
apt clean


Adesso synaptic funziona bene. Risolto.

Ora mi domando come avrei potuto fare senza copiare il file mancate (apt-listchanges) e le keyring ?
Grazie ancora.
Categorie: Forum Debianizzati

Re: Raspberry pi e fastweb

Mar, 24/07/2018 - 07:41
Può darsi che l'operatore filtri il traffico attraverso quella porta, ti suggerisco di contattarli o aspettiamo qualcuno che abbia esperienza con questo tipo di operatore perché io non ce ne ho mai avuto a che fare
Aggiornaci!
Categorie: Forum Debianizzati

Re: Installazione stampante HP Officejet J3680

Mar, 24/07/2018 - 06:21
Puoi fornire il log dell'installer ? Quando l'installer si avvia, presenta una riga in cui indica il nome del file di log (ad esempio, Installer log saved in: hplip-install_Tue-24-Jul-2018_06:19:50.log)
Categorie: Forum Debianizzati

Re: Guida ET

Lun, 23/07/2018 - 20:53
Ernestus ha scritto:Si il video gioco utilizza ancora le librerie OSS per cui per far sentire l'audio occorre uno script che carichi le librerie ALSA 32 bit. Purtroppo è difficile da reperire in rete per cui molti link sono non funzionanti (compresi sul wiki ufficiale di Debian).
Ma le librerie sono incluse nello script ?
Categorie: Forum Debianizzati

Re: debian ssd e trim

Lun, 23/07/2018 - 20:51
Selky ha scritto:Quesito Risolto
Grazie Selky per averci aggiornato al posto del richiedente utente pota. Contrassegno la discussione come risolta.
Categorie: Forum Debianizzati

Re: Guida ET

Lun, 23/07/2018 - 19:11
Si il video gioco utilizza ancora le librerie OSS per cui per far sentire l'audio occorre uno script che carichi le librerie ALSA 32 bit. Purtroppo è difficile da reperire in rete per cui molti link sono non funzionanti (compresi sul wiki ufficiale di Debian).
Categorie: Forum Debianizzati

Re: debian ssd e trim

Lun, 23/07/2018 - 13:20
Quesito Risolto
Categorie: Forum Debianizzati

Re: Scheda di rete INTEL I219-V non riconosciuta

Lun, 23/07/2018 - 11:09
Ciao s3v,
ho provato a fare un tentativo per eliminare il problema delle keyring. Ho copiato tutti i files della cartella apt da un'altra macchina funzionante, dopo ho commentato i vecchi repository ed ho aggiunto quelli che mi hai detto tu :

# repository principale
deb http://ftp.it.debian.org/debian stretch main contrib non-free
# security
deb http://security.debian.org/debian-security stretch/updates main contrib
# backports
deb http://ftp.it.debian.org/debian/ stretch-backports main contrib non-free


bene sembrava tutto funzionante, non ha chiesto più le chiavi, ma quando ho provato ad installare un programma da synaptic mi ha dato quest'altro errore:

W: Download is performed unsandboxed as root as file '/var/cache/apt/archives/partial/bleachbit_1.12-1_all.deb' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permesso negato)

ho dimenticato qualcosa ?
Grazie
Categorie: Forum Debianizzati

Re: Installazione stampante HP Officejet J3680

Dom, 22/07/2018 - 22:40
posso riportare gli errori perchè sono scritti in rosso:

error: debian-9.5 version is not supported, so all dependencies may not be installed. However trying to install using debian-9.4 version packages.
error: A required dependency 'pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)' is still missing.
error: A required dependency 'pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))' is still missing.
error: A required dependency 'pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)' is still missing.
error: A required dependency 'pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))' is still missing.
error: Installation cannot continue without these dependencies.
error: Please manually install this dependency and re-run this installer.
Categorie: Forum Debianizzati