Forum Debianizzati

Re: Intel Management Engine (ME)

Forum Debianizzati - Ven, 20/10/2017 - 14:14
diciamo che ho fatto una sintesi un po' frettolosa, grazie per il contributo.
Categorie: Forum Debianizzati

Re: Intel Management Engine (ME)

Forum Debianizzati - Ven, 20/10/2017 - 14:09
dring ha scritto:P
Il Management Engine (ME), parte di Intel AMT, è una CPU separata che può eseguire e controllare un computer anche quando è spento.

Se per spento intendi che non è alimentato, non è possibile controllare una macchina senza energia e trasferimento di dati!
Quindi è più corretto dire che il computer è controllabile se connesso ed alimentato con una linea elettrica (o in qualche modo con un fonte di energia) oltre che essere collegato ad una linea di comunicazione dati, tale controllo è attuabile anche quando il sistema operativo o il bios pricipale non è caricato e attivo, dato che la CPU di cui parli è in grado di impartire ordini al sistema.
Qualsiasi CPU necessita di energia per funzionare.
Descrivere la questione come hai fatto tu, sa un po' di stregoneria.....
Categorie: Forum Debianizzati

Intel Management Engine (ME)

Forum Debianizzati - Ven, 20/10/2017 - 12:18
Per chi vuole hardware libero, in questo caso la CPU Intel libera da "vPro enabled" (AMT).
Le CPU recenti di Intel richiedono un binario chiamato "Engine Management" (Intel ME o ME per brevità).
Questo binario è una delle tre parti necessarie se un'azienda sceglie di utilizzare la tecnologia Active Management di Intel (AMT).
Il Management Engine (ME), parte di Intel AMT, è una CPU separata che può eseguire e controllare un computer anche quando è spento.
Ora Purism è riuscita nell'impresa di disabilitare Intel ME.
https://puri.sm/posts/purism-librem-laptops-completely-disable-intel-management-engine/
Rimuovere completamente il motore di gestione è il passo successivo al di là della disabilitazione.
Coreboot include anche un altro binario, l'Intel FSP, un binario meno preoccupante ma ancora importante a cui Purism dedicherà tempo e risorse per rimuoverlo.
Queste sono notizie che mi piacciono!
Categorie: Forum Debianizzati

antivirus 2017

Forum Debianizzati - Ven, 20/10/2017 - 08:01
Ho guardato la comparativa degli antivirus su Av-Comparativers e vorrei un vostro consiglio antivirus ke sia affidabile, ma anche leggero che non occupi troppe risorse di sistema.
La mia scelta ricade tra:
Bitdefender
Kaspersky
Norton
Panda
McAfee
Qualche antivirus consiglio?
Categorie: Forum Debianizzati

Re: Cosa succede a Testing?

Forum Debianizzati - Ven, 20/10/2017 - 01:26
A vantaggio di qt5?
Categorie: Forum Debianizzati

Re: Cosa succede a Testing?

Forum Debianizzati - Ven, 20/10/2017 - 01:21
A giudicare dai changelog, c'è in atto la rimozione delle qt4.
https://lists.debian.org/debian-devel-a ... 00006.html
Categorie: Forum Debianizzati

Re: Debian Stretch TL-WN823N aiuto per installare i driver?

Forum Debianizzati - Ven, 20/10/2017 - 01:12
Basandosi sui risultati di wikidevi esistono due [1][2] versioni della pennetta, dovrebbero comunque essere entrambe supportate dal kernel di Stretch.
Accertati che il pacchetto "firmware-realtek" sia installato (lo trovi in non-free).

Se non dovesse bastare ti suggerisco di usare questo script usando l'opzione "--tipo=rete".

[1] https://wikidevi.com/wiki/TP-LINK_TL-WN823N_v1
[2] https://wikidevi.com/wiki/TP-LINK_TL-WN823N_v2
Categorie: Forum Debianizzati

Cosa succede a Testing?

Forum Debianizzati - Ven, 20/10/2017 - 00:39
Ho installato in una macchina nuova Testing. Ora, ci sono diversi motivi oer essere sconcerati.
Mancano pacchetti come Amarok, Libreoffice-kde, tutti i pacchetti di localizzazione per lo stesso KDE.
Inoltre, per motivi a me ignoti Libreoffice (che già appunto manca di Libreoffice-kde
che migliorava parecchio la resa) è senza icone: tutti i tasti dei menu sono le etichette del testo
e nei menu delle opzioni vedo soltanto la voce ma non la casella per spuntare l'opzione desiderata.
Vorrei capire se solo io ho questi problemi o se Testing sta attraversando un periodo di "crisi"...

m
Categorie: Forum Debianizzati

Debian Stretch TL-WN823N aiuto per installare i driver?

Forum Debianizzati - Ven, 20/10/2017 - 00:08
Salve ragazzi. Ho aquistato il TP-Link TP-WN823N ma non riesco ad installare i driver.

Qualcuno ha sa come fare?

Debian 9.2 Stretch KDE
Categorie: Forum Debianizzati

Re: Configurazione Openbox

Forum Debianizzati - Gio, 19/10/2017 - 21:05
Buonasera,

il pacchetto è correttamente installato. In precedenza ho usato Debian (istallato mediante live cd nella versione XFCE) in dual boot con Windows e riuscivo perfettamente, previo inserimento delle credenziali di root, ad accedere alla suddetta partizione direttamente da file menager. Per tale motivo escludo sia un problema di Windows.

Ringrazio per il gentile tempo concesso.
Categorie: Forum Debianizzati

Re: Blocco di debian all'avvio

Forum Debianizzati - Gio, 19/10/2017 - 19:32
Grazie, il problema era proprio quello. Ora ho tolto gli UUID per sostituirli con la vecchia dicitura /dev/sda*
Categorie: Forum Debianizzati

Re: Configurazione Openbox

Forum Debianizzati - Gio, 19/10/2017 - 19:31
Prova a controllare se "ntfs-3g" è installato:
apt policy ntfs-3g

Se non lo è, installalo.

P.S. Non avendo Windows non ho molta dimestichezza con l'argomento.
Per sentito dire, forse devi anche disabilitare il fastboot di Windows o comunque devi accertarti che Windows smonti le partizioni allo spegnimento.
Categorie: Forum Debianizzati

Re: Guida Server Lamp

Forum Debianizzati - Gio, 19/10/2017 - 19:23
Grazie, appena aggiorno farò sapere come è andata.
Categorie: Forum Debianizzati

Sito per training...

Forum Debianizzati - Gio, 19/10/2017 - 18:10
Ciao a tutti!
Sapete se e' possibile scaricare un sito web per training H@A@K?
Grazie!
Categorie: Forum Debianizzati

Re: Blocco di debian all'avvio

Forum Debianizzati - Gio, 19/10/2017 - 17:03
fstab, devi aggiornare i nuovi UUID delle partizioni.
Categorie: Forum Debianizzati

Re: Guida Server Lamp

Forum Debianizzati - Gio, 19/10/2017 - 17:01
@dring
A differenza tua, su Jessie non avevo ancora installato MariaDB.
In sostanza nel mio caso è successo che durante l'upgrade a Stretch mysql-client non si è aggiornato mentre mysql-server è stato rimosso.

Ovviamente installando i due pacchetti default-mysql-server e default-mysql-client ho risolto (10 minuti fa). Senza server non potevo utilizzare il controllo dello stato, l'avvio ecc...
Il tutto ora funziona:
# service mysql start
[ ok ] Starting MariaDB database server: mysqld.

# service mysql status
[info] /usr/bin/mysqladmin  Ver 9.1 Distrib 10.1.26-MariaDB, for debian-linux-gnu on x86_64
Copyright (c) 2000, 2017, Oracle, MariaDB Corporation Ab and others.

Server version      10.1.26-MariaDB-0+deb9u1
Protocol version   10
Connection      Localhost via UNIX socket
UNIX socket      /var/run/mysqld/mysqld.sock
Uptime:         9 sec

Threads: 1  Questions: 92  Slow queries: 0  Opens: 33  Flush tables: 1  Open tables: 27  Queries per second avg: 10.222.

# service mysql stop
[ ok ] Stopping MariaDB database server: mysqld.

 # service mysql status
[info] MariaDB is stopped..


Per il resto non so, devo ancora lavorarci dietro.
Categorie: Forum Debianizzati

[RISOLTO] Blocco di debian all'avvio

Forum Debianizzati - Gio, 19/10/2017 - 16:58
Sto reinstallando debian testing sul mio pc ma ogniqualvolta abilito il multiarch con il comando
# dpkg --add-architecture i386 && apt update

al successivo riavvio, il sistema va in blocco, la partizione di root va in sola lettura, non mi si avvia X e resto solo con la linea di comando.

L'unico comando che ho dato prima del precedente è la copia di una serie di file (sources.list e cartella sources.list.d, fstab), precedentemente salvati, dal desktop in /etc
Qual è il problema?

Grazie
Categorie: Forum Debianizzati

OpenVPN Remapping 1:1

Forum Debianizzati - Gio, 19/10/2017 - 16:44
Salve,
Sono nuovo di questo forum e quindi prima di tutto faccio un saluto generale a chi leggerà e deciderà di aiutarmi.
Il problema da me riscontrato è il seguente :
Ho un Server su cui gira OpenVPN all'indirizzo 10.8.1.1 e un altro Server su cui gira un'applicazione all'indirizzo 192.168.1.53.
Ora quello che voglio fare è mascherare questo indirizzo, essendo un indirizzo largamente utilizzato. Pensavo di fare un remapping 1:1 con NETMAP.

1) nel file di configurazione del server ho inserito il comando di push con la nuova rotta (es. 192.168.10.53)
2) Poi sono andato a giocare con iptables inserendo le seguenti regole :
iptables -t nat -A PREROUTING -i tun0 -d 192.168.10.0/24 -j NETMAP --to 192.168.1.0/24
iptables -t nat -A POSTROUTING -s 10.8.1.0/24 -d 192.168.1.0/24 -j MASQUERADE

Ora sembra funzionare tutto, nel senso che pingando dal client riesco a raggiugnere la rotta 192.168.10.53. Essendo questa rotta fittizia ed essendo tradotta solo dal server su cui gira OpenVPN ho la ragionevole certezza che i pacchetti passino per questo server. Il mio problema è che provando con tracert 192.168.10.53 mi aspettavo come primo hop quello del server di OpenVPN (10.8.1.1) e invece il primo hop è proprio 192.168.10.53.
La mia domanda è la seguente : é normale che risulti questo indirizzo come primo hop (quindi magari fa una traduzione per qualche motivo a me sconosciuto) oppure c'è qualche errore?
Categorie: Forum Debianizzati

Re: Guida Server Lamp

Forum Debianizzati - Gio, 19/10/2017 - 16:33
Questo mio pc ha ancora jessie con installato lamp, prima mysql poi MariaDB.
Fra un po' aggiornerò a Stretch ed ho paura che mi ritroverò coi problemi di Selky.
In effetti non conosco le modalità di passaggio da un pacchetto, mysql, all'altro MariaDB e perché vengono mantenuti i vecchi pacchetti.
Categorie: Forum Debianizzati

Re: Rsieze partizione senza reboot

Forum Debianizzati - Gio, 19/10/2017 - 16:18
Mentre scrivevo il post mi è venuta in mente la possibile causa: la tabella delle partizione non è stata riletta.

partprobe
resize2fs /dev/vda1
resize2fs 1.42.12 (29-Aug-2014)
Filesystem at /dev/vda1 is mounted on /; on-line resizing required
old_desc_blocks = 13, new_desc_blocks = 25
The filesystem on /dev/vda1 is now 104857344 (4k) blocks long.


Et voilà

df -h /
File system     Dim. Usati Dispon. Uso% Montato su
/dev/vda1       394G  168G    209G  45% /
Categorie: Forum Debianizzati
Condividi contenuti