Forum Debianizzati

Re: Risoluzione video Mint errata

Forum Debianizzati - Ven, 27/10/2017 - 00:46
Consiglio spassionato, dopo un mese nessuno è intervenuto, forse ti conviene chiedere in un forum dove mint è più conosciuta.

P.S.
Se dovesse capitarti di chiedere ancora per Mint o altre derivate, apri la discussione nella sezione apposita Derivate da Debian
Oltre a tenere ordine nel forum, non si perderebbe in off-topic con maggior rischio di essere ignorata.

P.S.2
I miei sono solo suggerimenti e non critiche.
Categorie: Forum Debianizzati

Re: MATE system monitor

Forum Debianizzati - Ven, 27/10/2017 - 00:28
@dring
nel senso che Stretch ora è alla 9.2 e non viene riportato (c'è solo 9) mentre per Jessie sì?
Categorie: Forum Debianizzati

[RISOLTO]GRUB2 Boot da sd

Forum Debianizzati - Gio, 26/10/2017 - 21:50
Mi hanno dato un vecchio netbook funzionante ma con l'hd con costanti problemi di magic number sui quali mi sono arreso, tralascio giorni di capocciate sugli spigoli e arrivo alla situazione attuale:
  • hd funzionante ma totalmente inaffidabile (parte 1/3)
  • grub funzionante e affidabile
  • computer vecchio che non prevede il boot da sd (emachine e350)
Allora mi sono detto linux parte e gira da ogni cosa.... ora lo faccio partire da sd, e invece....

ho fatto un upgrade del grub in quale mi ha rilevato il sistema su sd e aggiunto alla lista
quando pero vado ad avviare da li mi dice
no such device... uuid della sd
hd1 cannot get c/h/s
you need to load kernel first

Allora ho letto che bisognava attivare la sd direttamente nel grub e quindi
# echo "mmc_core" >> /etc/initramfs-tools/modules
# echo "mmc_block" >> /etc/initramfs-tools/modules
# echo "sdhci" >> /etc/initramfs-tools/modules
# echo "sdhci-pci" >> /etc/initramfs-tools/modules
# update-initramfs -u -k all

Ma niente continua a darmi quell'errore... sono a corto di idee
Categorie: Forum Debianizzati

Re: Mancato caricamento GLX dopo aggiornamento

Forum Debianizzati - Gio, 26/10/2017 - 21:19
Help me: qualche suggerimento per il mio problema?
Categorie: Forum Debianizzati

Re: MATE system monitor

Forum Debianizzati - Gio, 26/10/2017 - 21:16
Che siano diverse è vero, perché con la più nuova dare meno informazioni rispetto alla vecchia?
Categorie: Forum Debianizzati

Re: MATE system monitor

Forum Debianizzati - Gio, 26/10/2017 - 20:27
Forse perchè sono due diverse versioni di mate?
Categorie: Forum Debianizzati

MATE system monitor

Forum Debianizzati - Gio, 26/10/2017 - 19:35
Con Stretch ho notato che MATE system monitor non fa comparire il numero della Point Release, ma solo "9".
Invece con Jessie ho ad es. "8.9".




PERCHÈ?
Categorie: Forum Debianizzati

Re: recupero partition table

Forum Debianizzati - Gio, 26/10/2017 - 11:33
l'unica volta che mi sono trovato in situazione simile (solo la tabella partizioni sovrascritta per sbaglio) ho risolto azzerando i primi 512 bytes del disco e lasciando fare a programmi di recupero, ai tempi testdisk nemmeno c'era, tanto per dire.
un comando simile a
dd if=/dev/zero of=/dev/sdX bs=512 count=1

ovviamente operazione molto rischiosa senza garanzia di recupero dati, menomale che hai il backup
poi se cerchi sul forum esistono altri casi simili
Categorie: Forum Debianizzati

Re: colori terminale remmina

Forum Debianizzati - Gio, 26/10/2017 - 10:40
Risolto, sulla singola configurazione, bisogna andare in advanced e selezionare Terminal color scheme
Categorie: Forum Debianizzati

[RISOLTO] colori terminale remmina

Forum Debianizzati - Gio, 26/10/2017 - 10:19
Ciao a tutti,
uso remmina per lavoro e mi collego spesso in SSH, i colori di default non mi piacciono e ho cercato in tutti i modi di cambiarli, ma senza successo, ho scaricato i nuovi temi e sono andato in:
preferenze->Terminale
ho caricato il nuovo tema colori, mi fa vedere che i colori me li cambia, ma poi in realtà quando mi collego in ssh alla macchina ho sempre lo stesso colore di default.
Avete idee?
Grazie.
Categorie: Forum Debianizzati

Re: recupero partition table

Forum Debianizzati - Gio, 26/10/2017 - 09:58
La tabella delle partizioni originale di /dev/sda è ora su /dev/sdb, per ripristinarla io farei:
sfdisk -d /dev/sdb > part_table_sdb
sfdisk -d /dev/sda > part_table_sda

così salvo le tabelle dei due dischi
poi
sfdisk -d /dev/sda < part_table_sdb

Ciao

EDIT:
mi sa che non funziona così....il problema è ripristinare /dev/sdb che è sovrascritto......giusto?
bisogna cercare un'altra strada...

EDIT2: puoi usare testdisk per ricostruire la tabella e riscriverla sul disco
Categorie: Forum Debianizzati

Re: vecchio pc ogni tanto segmentation fault

Forum Debianizzati - Mer, 25/10/2017 - 22:17
personalmente proverei ad utilizzare un kernel meno recente
es
https://packages.debian.org/jessie/linux-image-3.16.0-4-amd64
Categorie: Forum Debianizzati

Re: vecchio pc ogni tanto segmentation fault

Forum Debianizzati - Mer, 25/10/2017 - 21:05
aggiornamento, ora e' uscito questo messaggio mentre scrivevo in vim:

root@deb9-2g:~# [ 1283.040040] ------------[ cut here ]------------
[ 1283.044024] WARNING: CPU: 0 PID: 0 at /build/linux-EAZfyE/linux-4.9.51/kernel/time/timer.c:1328 call_timer_fn+0x105/0x110
[ 1283.044024] timer: fib6_gc_timer_cb+0x0/0x20 preempt leak: 00000100 -> 000010f8
[ 1283.044024] Modules linked in: nouveau ppdev edac_mce_amd edac_core pcspkr k8temp mxm_wmi wmi serio_raw video parport_pc shpchp ttm drm_kms_helper drm evdev i2c_algo_bit
sg ns558 nv_tco snd_mpu401_uart gameport parport snd_rawmidi snd_seq_device snd soundcore button ip_tables x_tables autofs4 ext4 crc16 jbd2 crc32c_generic fscrypto ecb glue_
helper lrw gf128mul ablk_helper cryptd aes_x86_64 mbcache hid_generic usbhid hid sd_mod ata_generic ohci_pci ehci_pci ohci_hcd ehci_hcd pata_amd psmouse sata_nv r8169 mii li
bata scsi_mod usbcore usb_common i2c_nforce2
[ 1283.044024] CPU: 0 PID: 0 Comm: swapper/0 Not tainted 4.9.0-4-amd64 #1 Debian 4.9.51-1
[ 1283.044024] Hardware name: K8NF4G-SATA2/K8NF4G-SATA2, BIOS P1.70 03/15/2006
[ 1283.044024] 0000000000000000 ffffffff93329974 ffff996fbbc03e58 0000000000000000
[ 1283.044024] ffffffff93076eae 0000000000000001 ffff996fbbc03eb0 0000000000000100
[ 1283.044024] ffffffff935c50a0 ffffffff93cd6480 0000000000000000 ffffffff93076f2f
[ 1283.044024] Call Trace:
[ 1283.044024] <IRQ> [ 1283.044024] [<ffffffff93329974>] ? dump_stack+0x5c/0x78
[ 1283.044024] [<ffffffff93076eae>] ? __warn+0xbe/0xe0
[ 1283.044024] [<ffffffff935c50a0>] ? fib6_run_gc+0x100/0x100
[ 1283.044024] [<ffffffff93076f2f>] ? warn_slowpath_fmt+0x5f/0x80
[ 1283.044024] [<ffffffff935c5029>] ? fib6_run_gc+0x89/0x100
[ 1283.044024] [<ffffffff935c50a0>] ? fib6_run_gc+0x100/0x100
[ 1283.044024] [<ffffffff930e40f5>] ? call_timer_fn+0x105/0x110
[ 1283.044024] [<ffffffff930e4524>] ? run_timer_softirq+0x1d4/0x430
[ 1283.044024] [<ffffffff930f4cd0>] ? tick_sched_handle.isra.12+0x50/0x50
[ 1283.044024] [<ffffffff930f4ca0>] ? tick_sched_handle.isra.12+0x20/0x50
[ 1283.044024] [<ffffffff930f4d08>] ? tick_sched_timer+0x38/0x70
[ 1283.044024] [<ffffffff9360b0d5>] ? __do_softirq+0x105/0x290
[ 1283.044024] [<ffffffff9307cf8e>] ? irq_exit+0xae/0xb0
[ 1283.044024] [<ffffffff9360aeee>] ? smp_apic_timer_interrupt+0x3e/0x50
[ 1283.044024] [<ffffffff9360a202>] ? apic_timer_interrupt+0x82/0x90
[ 1283.044024] <EOI> [ 1283.044024] [<ffffffff93607e52>] ? native_safe_halt+0x2/0x10
[ 1283.044024] [<ffffffff93607b9a>] ? default_idle+0x1a/0xd0
[ 1283.044024] [<ffffffff930b96aa>] ? cpu_startup_entry+0x1ca/0x240
[ 1283.044024] [<ffffffff93d38f57>] ? start_kernel+0x443/0x463
[ 1283.044024] [<ffffffff93d38120>] ? early_idt_handler_array+0x120/0x120
[ 1283.044024] [<ffffffff93d38408>] ? x86_64_start_kernel+0x14c/0x170
[ 1283.044024] ---[ end trace 83b1a8a0730f0674 ]---

la cosa bella e' che non e' crashato tutto, ma sto continuando a scrivere
Categorie: Forum Debianizzati

vecchio pc ogni tanto segmentation fault

Forum Debianizzati - Mer, 25/10/2017 - 21:02
ho installato su un vecchio pc debian 9 64bit e ogni tanto mi esce un messaggio di segmentation fault
tipo questo:
[ 907.862258] apt-get[973]: segfault at 7fa94bd53000 ip 00007fa9452df761 sp 00007fff822d8c48 error 4 in libapt-pkg.so.5.0.1[7fa94519c000+1a9000]


a caso, a volta mentro scrivo con vim o altre cose del genere
tempo fa installai centos7 e mi usciva pure li segmentation fault come ora, pensavo che era dovuto al fatto che il pc in questione ha 1 solo processore e 1 solo core e che questa configurazione non e' supportata da centos7 allora ho installato debian9 e invece zac stesso problema

tempo fa ci installai freebsd e pare che funzionava bene, pero' mi piacerebbe piu' metterci debian
che posso provare a fare?
Categorie: Forum Debianizzati

recupero partition table

Forum Debianizzati - Mer, 25/10/2017 - 20:56
Buongiorno a tutti!

Mi sono sputtanato la tabella delle partizioni del mio disco dati dando un comando sbagliato (dd per clonare due dischi).
Ho lanciato
dd if=/dev/sda of=/dev/sdb bs=4096 conv=notrunc,noerror

Mi sono accorto subito della cavolata e ho dato immediatamente un CTRL-C. Nel frattempo però dd mi aveva copiato una tabella di partizione sull'altra.
Il computer è acceso e quindi continuo a vedere il disco con la tabella di partizione vecchia.

E' possibile recuperare in qualche modo 'sta dannata configurazione? I dati non li perdo perché li vedo. Forse ho perso una partizione con Windows 10 (ma non ne sono nemmeno sicuro (forse l'avevo già eliminata da tempo).

Attualmente fdisk -l mi da:

# fdisk -l
Disk /dev/sda: 238,5 GiB, 256060514304 bytes, 500118192 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00042ad4

Dispositivo Avvio Start Fine Settori Size Id Tipo
/dev/sda1 * 2048 122882047 122880000 58,6G 83 Linux
/dev/sda2 122882048 500117503 377235456 179,9G 83 Linux

Disk /dev/sdb: 1,8 TiB, 2000398934016 bytes, 3907029168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0x00042ad4

Dispositivo Avvio Start Fine Settori Size Id Tipo
/dev/sdb1 * 2048 122882047 122880000 58,6G 83 Linux
/dev/sdb2 122882048 500117503 377235456 179,9G 83 Linux

Invece gpart...

# sudo gpart /dev/sdb

Begin scan...
Possible partition(Linux ext2), size(99253mb), offset(1mb)
Possible partition(Linux ext2), size(1508475mb), offset(99254mb)
Possible partition(Windows NT/W2K FS), size(299149mb), offset(1607729mb)
Possible partition(Windows NT/W2K FS), size(849mb), offset(1906879mb)
Possible partition(Windows NT/W2K FS), size(299999mb), offset(1907728mb)

*** Fatal error: dev(/dev/sdb): seek failure.

Per essere sicuro di non avere le traveggole...
# df -h
File system Dim. Usati Dispon. Uso% Montato su
udev 3,9G 0 3,9G 0% /dev
tmpfs 785M 79M 706M 10% /run
/dev/sda1 58G 16G 40G 28% /
tmpfs 3,9G 3,1M 3,9G 1% /dev/shm
tmpfs 5,0M 4,0K 5,0M 1% /run/lock
tmpfs 3,9G 0 3,9G 0% /sys/fs/cgroup
/dev/sda2 177G 158G 11G 94% /home
/dev/sdb1 96G 19G 73G 21% /var
cgmfs 100K 0 100K 0% /run/cgmanager/fs
tmpfs 785M 92K 784M 1% /run/user/1000
/dev/sdb2 1,5T 190G 1,2T 14% /home/Ilic/Documenti

che direi che dimostra che a computer non riavviato le partizioni vengono ancora viste diversamente dalla partition table.

E ora?

Consigli?

Il backup ce l'ho. Anzi, ne ho due.
Vorrei evitare lo sbattimento di ricaricare tutto.

C'è modo di recuperare la tabella delle partizioni che è in uso ora?

Ciao. Ilic
Categorie: Forum Debianizzati

grub2 boot monitor+seriale

Forum Debianizzati - Mer, 25/10/2017 - 20:54
sto buttando il sangue per cercare di capire come fare per fare il boot contemporaneante da monitor e da porta seriale

al momento appare grub su entrambi i fronti, bootano entrambi, e ottengo la schermata per fare il login da entrambi i lati pero' sulla seriale, visualizzo non solo i messaggi del kernel ma anche "starting questo e quel servizio" invece sul monitor non vedo questi messaggi, solo i mesaggi del kernel

come posso fare per visaulizzare anche le linee starting service sul monitor?

questo e' l'/etc/default/grub attuale

RUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX="console=tty0 console=ttyS0,115200n8"
GRUB_INIT_TUNE="480 440 1"
GRUB_TERMINAL="console serial"
GRUB_SERIAL_COMMAND="serial --unit=0 --speed=115200 --word=8 --parity=no --stop=1"


datemi una mano
grazie
Categorie: Forum Debianizzati

Monitorare carico virtual host apache

Forum Debianizzati - Mer, 25/10/2017 - 13:03
Ho un server con debian wheezy con diverse istanze di owncloud.
Capita che il server sia parecchio sotto carico e vorrei individuare qual'è il virtual host che sta ricevendo più richieste.
Ho provato ad installare apachetop ma il suo output non riposta la parte dell'url, neanche con l'opzione -p.
Anche in /var/log/apache2/access.log non vedo quale virtualhost è stato chiamato.

last hit: 10:57:33         atop runtime:  0 days, 00:00:30             10:57:37
All:           31 reqs (   1.1/sec)         43.5K ( 1535.9B/sec)    1436.8B/req
2xx:      30 (96.8%) 3xx:       0 ( 0.0%) 4xx:     1 ( 3.2%) 5xx:     0 ( 0.0%)
R ( 30s):      31 reqs (   1.0/sec)         43.5K ( 1484.7B/sec)    1436.8B/req
2xx:      30 (96.8%) 3xx:       0 ( 0.0%) 4xx:     1 ( 3.2%) 5xx:     0 ( 0.0%)

 REQS REQ/S    KB KB/S URL
   14  0.61  25.8  1.1*/remote.php/webdav/
    2  0.10   2.1  0.1 /index.php/apps/files/ajax/upload.php
    1  0.04   1.1  0.0 /remote.php/webdav/DATIxxxxxxxxxxxx
    1  0.04   1.0  0.0 /remote.php/webdav/Archivi
    1  0.03   1.0  0.0 /remote.php/webdav/CAD
    1  0.04   1.1  0.0 /remote.php/webdav/BACKUPxxxxxxxxxxx
    1  0.04   1.1  0.0 /remote.php/webdav/xxxxxxx/xxxxxxxxxx
    1  0.04   1.1  0.0 /remote.php/webdav/BACKUP%20PC%20AMMINISTRAZIONE
    1  0.04   1.1  0.0 /remote.php/webdav/DOCUMENTI
    1  0.04   1.1  0.0 /remote.php/webdav/xxxxxxx/Clienti/VS%20Frame/Disegni%20condivisi
    1  0.04   1.1  0.0 /remote.php/webdav/xxxxxxx/Risorse/xxxxxxxxx
    1  0.04   0.9  0.0 /remote.php/webdav/BACKUPxxxxxxxxxxxxx
    1  0.04   1.1  0.0 /remote.php/webdav/xxxxxxx/Clienti/Plasco/CAD
    1  0.08   1.1  0.1 /remote.php/webdav/Disegni%20condivisi
    1  0.11   1.0  0.1 /remote.php/webdav/Xmask
    1  0.20   1.1  0.2 /remote.php/webdav/xxxxxxxxx


Cosa consigliate?
Categorie: Forum Debianizzati

Clash royals character coming for Halloween update?

Forum Debianizzati - Mer, 25/10/2017 - 10:00
If you look in the events page you will see in 3days and in how many hours another event. It has a pumpkin barbarian and that giant skeleton character from clash royale (not sure what the actual name is). Is this the same character from clash royale or just a giant dressed up?


Please Help !
Thanks !

I didn't find the right solution from the internet.

References:
-https://forum.supercell.com/showthread.php/1633580-Clash-royals-character-coming-for-Halloween-update
-animated videos
Categorie: Forum Debianizzati

Has anyone got the special halloween obstacle yet?

Forum Debianizzati - Mer, 25/10/2017 - 09:59
Hi all! I was just wondering if anyone has been lucky enough for the special halloween obstacle for 2017 to spawn on their base! If so, please leave your player tag/id below so I could check it out!!!


Please Help !
Thanks !

I didn't find the right solution from the internet.

References:
-https://forum.supercell.com/showthread.php/1634327-Has-anyone-got-the-special-halloween-obstacle-yet
-explainer videos
Categorie: Forum Debianizzati
Condividi contenuti