Forum Debianizzati

Re: Debian 9.6 si blocca

Forum Debianizzati - Ven, 04/01/2019 - 20:29
Aggiornamento:

Con l'aiuto di Aki, che in privato mi ha dato una grossissima mano, ho settato i tasti magici SysRq.
Con il comando

cat /proc/sys/kernel/sysrq

ricevete un valore che corrisponde ai vari tipi di comandi SysRQ attivi. Nel mio caso era 438 quindi seguendo questa tabella

    2 = 0x2 - enable control of console logging level
    4 = 0x4 - enable control of keyboard (SAK, unraw)
    8 = 0x8 - enable debugging dumps of processes etc.
    16 = 0x10 - enable sync command
    32 = 0x20 - enable remount read-only
    64 = 0x40 - enable signalling of processes (term, kill, oom-kill)
    128 = 0x80 - allow reboot/poweroff
    256 = 0x100 - allow nicing of all RT tasks
come mi ha fatto notare Aki quelli attivi sono: 2+4+16+32+128+256=438.
A me serviva "enable debugging dumps of processes etc.", al momento disattivato. Per ovviare al problema c'è il comando

echo "number" >/proc/sys/kernel/sysrq

con al posto di number il valore scelto. Se il valore è 1 vengono attivati tutti. Ma occhio che al riavvio i parametri torneranno come prima quindi se volete rendere i cambiamenti definitivi basta dare

nano /etc/sysctl.d/99-sysctl.conf

e togliere il commento da "kernel.sysrq = 1".
Per qualsiasi altra informazione utile vi rimando qui https://github.com/torvalds/linux/blob/master/Documentation/admin-guide/sysrq.rst. Ancora una volta ringrazio Aki che mi ha aiutato moltissimo in questa fase.

Adesso, grazie alla combinazione di tasti Alt+SysRq+c riesco a simulare un crash. La domanda è: devo fare delle operazioni preliminari?
Perchè tra i file di kdump-tools c'è lo script per caricare il kernel kdump, (/etc/init.d/kdump-tools). Devo avviare lo script e poi simulare il crash e riavviare? Se sì, poi dove trovo i file diagnostici?
Categorie: Forum Debianizzati

Re: Problema all’avvio di Debian

Forum Debianizzati - Ven, 04/01/2019 - 19:40
non devi risolvere nulla perchè quei messaggi sono ininfluenti https://www.linuxquestions.org/question ... 175605357/
Categorie: Forum Debianizzati

Re: OpenVPN gateway

Forum Debianizzati - Ven, 04/01/2019 - 18:10
Grazie per la risposta Aki. Io comunque non ho un router in senso stretto, ho proprio un miniPC (intel atom) su cui ho installato, tra le varie, pppoeconf. Il dispositivo ha due porte ethernet, una per la LAN ed una che funge da WAN collegata al mio modem-router DSL (configurata in modalità bridge). Tramite IPTABLES faccio un semplice filtraggio + NAT di tutto il traffico in entrata ed in uscita alla LAN. Le mie interfacce di rete sono br0 (eth0+wlan0) e ppp0 (eth1) attualmente.

Quello che volevo capire io era appunto come configurare openvpn sul mio miniPC per far passare tutto il traffico attraverso il server VPN del servizio che andrei a sottoscrivere.

Nel caso di collegamento diretto al server di un PC qualsiasi della lan la cosa sembra molto semplice (il fornitore che userei fornisce già i file di configurazione di openvpn client), mentre per quanto riguarda la configurazione del client sul mio mini PC non ho trovato nulla di specifico.
Al momento leggendo qua e la mi sono fatto l'idea che mi basti installare openvpn e configurarlo col file del provider, quindi configurare iptables per reindirizzare tutto il traffico all'interfaccia tun0 che openvpn crea (attualmente tutto il mio traffico è invece indirizzato a ppp0).
Sicuramente nei prossimi giorni proverò a fare così, però appunto prima di provare ho voluto chiedere lumi essendo un argomento totalmente nuovo per me. Anche perché non so cosa possa succedere se decido di usare i DNS del fornitore della VPN, nel senso che attualmente per la risoluzione degli indirizzi locali uso un mio server DNS (non mi pare di avere la possibilità di indicare i DNS del fornitore della VPN come forwarder di bind perché non mi pare siano pubblici). Comunque quest'ultimo aspetto è minoritario.
Categorie: Forum Debianizzati

Problema all’avvio di Debian (ACPI Error)

Forum Debianizzati - Ven, 04/01/2019 - 16:21
Ciao ragazzzi mi servirebbe una mano in quanto dopo l’ultimo aggiornamento che ho fatto dei pacchetti Debian mi viene fuori questa schermata all’avvio del PC prima di caricarmi la schermata utente desktop.

Link foto schermata:

https://ibb.co/rwGZTXG

Cosa può essere? Come posso risolvere?
Grazie mille
Categorie: Forum Debianizzati

Re: Problema caricamento immagine forum

Forum Debianizzati - Ven, 04/01/2019 - 14:34
che formato è la tua immagine?
Quanto è pesante in kB?
e comunque attieniti alle direttive del forum, vedi in FAQ:
"Posso inserire delle immagini?
Puoi inserire delle immagini nei tuoi messaggi. Se l’amministratore permette gli allegati è possibile caricare delle immagini direttamente sulla Board, in alternativa devi fare un collegamento a un’immagine ospitata su un server di pubblico accesso, ad es. http://www.indirizzo-del-sito.com/immagine.gif. Non puoi inserire immagini che hai sul tuo PC (a meno che non abbia un server!) o immagini che si trovano dietro sistemi di autenticazione, come caselle di posta tipo yahoo o hotmail, siti protetti da codici di accesso, ecc. Per inserire l’immagine, puoi usare il comando BBCode [img]"
Categorie: Forum Debianizzati

Re: Problema caricamento immagine forum

Forum Debianizzati - Ven, 04/01/2019 - 14:34
che formato è la tua immagine?
Quanto è pesante in kB?
e comunque attieniti alle direttive del forum, vedi in FAQ:
"Posso inserire delle immagini?
Puoi inserire delle immagini nei tuoi messaggi. Se l’amministratore permette gli allegati è possibile caricare delle immagini direttamente sulla Board, in alternativa devi fare un collegamento a un’immagine ospitata su un server di pubblico accesso, ad es. http://www.indirizzo-del-sito.com/immagine.gif. Non puoi inserire immagini che hai sul tuo PC (a meno che non abbia un server!) o immagini che si trovano dietro sistemi di autenticazione, come caselle di posta tipo yahoo o hotmail, siti protetti da codici di accesso, ecc. Per inserire l’immagine, puoi usare il comando BBCode [img]"
Categorie: Forum Debianizzati

Re: Prestazioni 32 / 64 bit

Forum Debianizzati - Ven, 04/01/2019 - 11:55
Avendo due portatili dual core con 2 Gb di Ram (Lenovo recuperati da una fine certa all'Isola ecologica), confermo quanto scritto da Aki: con il 32Bit debian consuma meno Ram e con xfce4 sono velocissimi...
Categorie: Forum Debianizzati

[RISOLTO] Problema caricamento immagine forum

Forum Debianizzati - Ven, 04/01/2019 - 11:19
Buongiorno ragazzi ho un problema con Debian all’avvio e vorrei allegarvi la foto della schermata al post ma quando carico l’immagine e cerco di allegarla da telefono mi dice file immagine non valido... come mai?
Categorie: Forum Debianizzati

Problema caricamento immagine forum

Forum Debianizzati - Ven, 04/01/2019 - 11:19
Buongiorno ragazzi ho un problema con Debian all’avvio e vorrei allegarvi la foto della schermata al post ma quando carico l’immagine e cerco di allegarla da telefono mi dice file immagine non valido... come mai?
Categorie: Forum Debianizzati

Re: Installazione driver Nvidia

Forum Debianizzati - Ven, 04/01/2019 - 10:22
_Alex_ ha scritto:Per quanto riguarda il dongle usb sapreste aiutarmi?
Per poterti aiutare, dovresti cortesemente aprire una discussione specifica con tutti i dettagli del caso.
Categorie: Forum Debianizzati

Re: Mini wireless tl-wn823n

Forum Debianizzati - Ven, 04/01/2019 - 10:19
zambu ha scritto:Ma qui il problema non sembra essere l'installazione del driver dato che il dispositivo viene riconosciuto, ma qualcosa che avviene dopo, nell'accesso alla rete.
@zambu: la tua osservazione è pertinente, ma l’utente brunoS non ha fornito nessuna informazione di dettaglio (nonostante richiesto a spron battuto in tutti i post di altre discussioni e nel regolamento del forum), quindi potrebbe anche star usando un sistema con scheda di rete per niente o non del tutto configurata.
Categorie: Forum Debianizzati

Re: Mini wireless tl-wn823n

Forum Debianizzati - Gio, 03/01/2019 - 22:21
Ma qui il problema non sembra essere l'installazione del driver dato che il dispositivo viene riconosciuto, ma qualcosa che avviene dopo, nell'accesso alla rete.

Controllato la password?
Categorie: Forum Debianizzati

Re: OpenVPN gateway

Forum Debianizzati - Gio, 03/01/2019 - 21:53
wtf ha scritto:non voglio che ogni PC della mia lan stabilisca autonomamente un tunnel col servizio vpn, ma vorrei che fosse il mio router ha stabilire un unico tunnel che venga poi usato da tutti i dispositivi della mia LAN.
Sperando di non riferirti elementi che ti sono già noti, indipendentemente da fornitore di servizio prescelto, dovresti configurare un proxy sul modem-router-gateway e configurare quest'ultimo per utilizzare il client VPN per collegarti all'esterno con il fornitore di servizio VPN, mentre il proxy sul modem-router-gateway sarebbe utilizzato dai tuoi client per raggiungere l'esterno. Al contrario, se vuoi che la tua rete interna sia raggiungibile dall'esterno, il client VPN sul modem-router-gateway dovrebbe essere opportunamente configurato per consentirlo by-passando il proxy.
Categorie: Forum Debianizzati

Re: Blocco di caja pdf e visualizzatore immagini

Forum Debianizzati - Gio, 03/01/2019 - 18:52
Purtroppo no, nessun aggiornamento da segnalare.
Categorie: Forum Debianizzati

OpenVPN gateway

Forum Debianizzati - Gio, 03/01/2019 - 15:42
Ciao e Buon Anno a tutti.
Sto pensando di sottoscrivere un servizio VPN e pertanto vorrei configurare il mio gateway-router (un miniPC con debian stretch installata) per connettermi al suddetto servizio. In sostanza non voglio che ogni PC della mia lan stabilisca autonomamente un tunnel col servizio vpn, ma vorrei che fosse il mio router ha stabilire un unico tunnel che venga poi usato da tutti i dispositivi della mia LAN.
Ora anche qui sul debianizzati ho visto che ci sono un paio di guide dedicate ad OpenVPN, ma mi par di capire che trattino il caso per cui l'utente si crei proprio un server vpn, senza bisogno di appoggiarsi ad alcun servizio commerciale.
Avete qualche guida o consiglio più mirato per ottenere il risultato che mi sono prefisso?
Nel caso fosse utile potete vedere qui la pagina delle istruzioni per configurare un semplice client col servizio VPN che penso di usare.

Grazie in anticipo per ogni suggerimento e/o consiglio.
Categorie: Forum Debianizzati

Re: Errori con firmware scheda wi-fi

Forum Debianizzati - Gio, 03/01/2019 - 15:32
Mmmmhhhh, a questo punto mi viene il dubbio che possa essermi semplicemente partita la scheda wi-fi del mio nuc. È plausibile secondo voi la cosa?
Categorie: Forum Debianizzati

Re: Apt-get update va in loop

Forum Debianizzati - Gio, 03/01/2019 - 07:24
killer ha scritto:[..] di signal-xenial.list mi sembra ci sia solo un file comunque non mi serve quindi posso eliminarlo. Dopo averlo tolto ho provato a ridare apt-get update funziona di nuovo quasi del tutto
Con l’occasione, elimina anche gli altri file non necessari (ad esempio, i file di log). Felice tu abbia risolto: ricordati di contrassegnare la discussione come risolta al suo termine.

killer ha scritto:[..] Come faccio a fargli leggere i repo della vpn? Se non ricordo male di default Debian legge solo i repo http, quindi basta fargli installare apt-transport-https giusto?
Si, dovrebbe essere sufficiente. In senso lato, comunque, se possibile, suggerirei di limitare il più possibile l’utilizzo di programmi di repository di terze parti sopratutto se realizzati per altre distribuzioni oppure di tipo proprietario (vedi https://wiki.debian.org/DontBreakDebian )

killer ha scritto:ps: grazie per la dritta su C-c, effettivamente e' piu' comodo di
C-z
ps
kill -9 numeroDelProcesso

Prego, felice di esserti stato d’aiuto.
Categorie: Forum Debianizzati

Re: Raspberry pi e fastweb

Forum Debianizzati - Gio, 03/01/2019 - 00:59
Aki ha scritto:capocla ha scritto:Sembra che il problema fosse nel modem. Dopo che me lo hanno cambiato, sono riuscito ad accedere al pi in remoto.
Grazie per averci aggiornato. Contrassegno la discussione come risolta.

L'aggiornamento, tra l'altro, è pochi giorni fa. Non avrei mai potuto aggiornare questa discussione prima
Categorie: Forum Debianizzati

Re: Raspberry pi e fastweb

Forum Debianizzati - Mer, 02/01/2019 - 23:54
capocla ha scritto:Sembra che il problema fosse nel modem. Dopo che me lo hanno cambiato, sono riuscito ad accedere al pi in remoto.
Grazie per averci aggiornato. Contrassegno la discussione come risolta.
Categorie: Forum Debianizzati

Re: Apt-get update va in loop

Forum Debianizzati - Mer, 02/01/2019 - 23:43
Dal log che hai inviato sembrerebbe ci sia una configurazione "anomala" del gestore dei pacchetti:
root@dell330:/etc/apt# apt-get install -y debian-keyring debian-archive-keyring
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list.d/signal-xenial.list:1 and /etc/apt/sources.list.d/signal-xenial.list:2 configured multiple times in /etc/apt/sources.list.d/signal-xenial.list:1 and /etc/apt/sources.list.d/signal-xenial.list:2it_IT) is configured multiple times in /etc/apt/sources.list.d/signal-xenial.list:1 and /etc/apt/sources.list.d/signal-xenial.list:2configured multiple times in /etc/apt/sources.list.d/signal-xenial.list:1 and /etc/apt/sources.list.d/signal-xenial.list:2is configured multiple times in /etc/apt/sources.list.d/signal-xenial.list:1 and /etc/apt/sources.list.d/signal-xenial.list:2
[1]+  Ucciso                 

Ad esempio, dallo stralcio sopra riportato del log risulta che hai configurato alcuni repository di terze parti (perché ?) all'interno della configurazione di Debian, ed in particolare, che esistono una o più copie, forse, di questo file: "/etc/apt/sources.list.d/signal-xenial.list*"

Tale file deve essere cancellato in quanto interferisce con la configurazione di Debian, quindi, va impartito nuovamente il comando apt-get update.

Verifica se non sono presenti altri file "spuri", ad esempio, con il comando:
script log.txt
ls -lR /etc/apt/
exit

Infine, se può esserti utile, segnalo che l'interruzione dei programmi va eseguita, di solito, con CTRL-C e non con CTRL-Z (che ha un'altra funzione).
Categorie: Forum Debianizzati
Condividi contenuti