Forum Debianizzati

Re: Driver nvidia

Forum Debianizzati - Dom, 05/11/2017 - 22:53
Ho inoltre disinstallato il pacchetto lirc dato le numerose righe di errore in syslog
Categorie: Forum Debianizzati

Re: Driver nvidia

Forum Debianizzati - Dom, 05/11/2017 - 22:32
Questo è l'altro log
Categorie: Forum Debianizzati

Re: Driver nvidia

Forum Debianizzati - Dom, 05/11/2017 - 22:27
Il bugreport di bumblebee
Categorie: Forum Debianizzati

Re: Driver nvidia

Forum Debianizzati - Dom, 05/11/2017 - 22:17
Il server x è ripartito, il problema non è risolto ma il messaggio è cambiato
silvio@localhost:~$ optirun virtualbox
[  187.217455] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) Failed to load module "nouveau" (module does not exist, 0)

[  187.217512] [WARN]The Bumblebee server was not available.


ho fatto il reportbug ma è oltre 256kb, cerco un modo per inviarlo
Categorie: Forum Debianizzati

Re: partizionamento come variare e non fare danni

Forum Debianizzati - Dom, 05/11/2017 - 22:06
ovviamente hai un backup aggiornato vero?

comunque il modo più sicuro è quello di togliere la partizione estesa, quindi devi cancellare la home e la swap, a questo punto con la partizione estesa vuota puoi cancellare anche quella

ti resterà un disco con
spazio non allocato 1 Mb
sda1 root che potrai espandere a piacimento (es con gparted)
spazio non allocato 238 Gb

la situazione finale somiglierà a questa
spazio non allocato 1 Mb
sda1 root 30 Gb -primaria
sda2 home 235 Gb - primaria, vuota e con i dati da ricaricare

dovrai poi verificare la congruenza di fstab e degli UUID

sicuramente se il disco è pieno non è una soluzione rapida! non so se ci sono scorciatoie possibili, soprattutto a causa della partizione estesa così organizzata, ma personalmente con le partizioni preferisco pasticciare il meno possibile

tieni poi presente che ogni errore può costare caro, quindi vai cauto e sicuro su quello che fai
Categorie: Forum Debianizzati

Re: Driver nvidia

Forum Debianizzati - Dom, 05/11/2017 - 20:41
OK, credo puoi impartire il seguente comando senza particolari difficoltà:
apt-get remove xserver-xorg-video-nouveau

Quindi, reinstalla il pacchetto nvidia-kernel-dkms con il seguente comando (è possibile che con l'aggiornamento dei pacchetti si sia stato disinstallato qualcosa relativo al supporto drm per il driver Nvidia):
apt-get install --reinstall nvidia-kernel-dkms nvidia-installer-cleanup nvidia-legacy-check nvidia-alternative  nvidia-driver-bin  nvidia-driver-libs nvidia-kernel-375.82  nvidia-support nvidia-vdpau-driver    xserver-xorg-video-nvidia    nvidia-settings

Quindi, riavvia il computer e prova vedere se il server X riparte. In caso di mancata ripartenza, genera nuovamente il log. Se possibile, impartisci il seguente comando ed invia il file di log che genera:
bumblebee-bugreport
Categorie: Forum Debianizzati

Re: Driver nvidia

Forum Debianizzati - Dom, 05/11/2017 - 20:28
Il risultato della simulazione:
silvio@localhost:~$ su
Password:
root@localhost:/home/silvio# apt-get -s remove xserver-xorg-video-nouveau
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
  fonts-linuxlibertine fonts-sil-gentium fonts-sil-gentium-basic hyphen-en-us
  libbsh-java libreoffice libreoffice-help-en-us libreoffice-librelogo
  libreoffice-nlpsolver libreoffice-ogltrans libreoffice-pdfimport
  libreoffice-script-provider-bsh libreoffice-script-provider-js
  libreoffice-script-provider-python libreoffice-wiki-publisher mythes-en-us
  pkg-config
Usare "apt autoremove" per rimuoverli.
I seguenti pacchetti saranno RIMOSSI:
  task-desktop task-gnome-desktop xserver-xorg-video-all
  xserver-xorg-video-nouveau
0 aggiornati, 0 installati, 4 da rimuovere e 0 non aggiornati.
Remv task-gnome-desktop [3.39]
Remv task-desktop [3.39]
Remv xserver-xorg-video-all [1:7.7+19]
Remv xserver-xorg-video-nouveau [1:1.0.13-3]
root@localhost:/home/silvio# exit
exit
silvio@localhost:~$ optirun virtualbox
[  179.788817] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) [drm] Failed to open DRM device for pci:0000:01:00.0: -19

[  179.788892] [WARN]The Bumblebee server was not available.
silvio@localhost:~$
Categorie: Forum Debianizzati

Re: Driver nvidia

Forum Debianizzati - Dom, 05/11/2017 - 20:09
Dall'ultimo log che hai inviato, non risulta caricato in memoria il driver nvidia ed, inoltre, il server X non riconosce la presenza del supporto nvidia (mentre carica i moduli per il supporto dei driver nouveau per nvidia). Potrebbe essere utile disinstallare i pacchetti per il supporto del server X per il driver nouveau usando il comando:
apt-get -s remove xserver-xorg-video-nouveau

Nota che nel comando sopra riportato ho aggiunto l'opzione -s al fine di consentirti di effettuare una simulazione prima di toglierlo e rimuovere effettivamente il pacchetto.
Categorie: Forum Debianizzati

Re: Driver nvidia

Forum Debianizzati - Dom, 05/11/2017 - 19:29
eseguito update-initramfs -u, riavviato pc, corretto /etc/apt/sources.list e fatto update e upgrade.
in allegato il log dopo aver eseguito le operazioni sopra descritte.
Categorie: Forum Debianizzati

Re: Stretch non vede lettore mp3

Forum Debianizzati - Dom, 05/11/2017 - 19:28
Buonasera
Cosi per curiosità per vedere se andava con l'altro firmware quello originale ho fatto partire il lettore San-disk.
Allora con il firmware quello originale va è il lettore viene riconosciuto integralmente da Stretch e il mio portatile !!!
Invece con il firmware open surce del progetto http://www.rockbox.org/ purtroppo non va
Faro sapere in seguito come va finire
Categorie: Forum Debianizzati

Re: Driver nvidia

Forum Debianizzati - Dom, 05/11/2017 - 19:05
No, dovresti impartire il seguente comando come utente root:
update-initramfs -u

Quindi riavviare il computer e rigenerare il log.

Inoltre, il sources.list continua ad essere errato; dovrebbe essere:
******************************************
/etc/apt/sources.list
******************************************
#
# deb cdrom:[Debian GNU/Linux 9.2.1 _Stretch_ - Official amd64 DVD Binary-1 20171013-13:09]/ stretch contrib main

deb http://ftp.it.debian.org/debian/ stretch main contrib non-free
deb-src http://ftp.it.debian.org/debian/ stretch main contrib non-free

deb http://security.debian.org/debian-security stretch/updates main contrib
deb-src http://security.debian.org/debian-security stretch/updates main contrib

# stretch-updates, previously known as 'volatile'
deb http://ftp.it.debian.org/debian/ stretch-updates main contrib
deb-src http://ftp.it.debian.org/debian/ stretch-updates main contrib

Quindi, come utente root, impartisci i seguenti comandi:
apt-get update
apt-get upgrade
apt-get dist-upgrade
Categorie: Forum Debianizzati

partizionamento come variare e non fare danni

Forum Debianizzati - Dom, 05/11/2017 - 19:04
Ho attualmente installato DEBIAN 8 (che uso come computer principale) con il seguente partizionamento:

1 spazio non allocato 1MB
2 SDA1 9,31 GB ROOT
3 SDA2 Extended 229,16 GB
SDA5 9,13 GB SWAP
spazio non allocato 1MB
SDA6 220,03 GB HOME

devo aver fatto un po di casino quando installai il disco è un SSD da 256GB

ora vado benissimo ma il problema è che le ROOT è zeppa!
mi sono letto alcuni post ma ho una grande confusione. Ho provato con GPARTED a fare dei test senza applicare i cambiamenti ma non riesco ad aumentare lo spazio del ROOT che vorrei portare a circa 30GB e poi vorrei eliminare la SWAP e fare come consigliato su altro post qui sul forum usando il file swap.

datemi qualche dritta e cosa utilizzare
grazie anticipato
Categorie: Forum Debianizzati

partizionamento come variare e non fare danni

Forum Debianizzati - Dom, 05/11/2017 - 19:04
Ho attualmente installato DEBIAN 8 (che uso come computer principale) con il seguente partizionamento:

1 spazio non allocato 1MB
2 SDA1 9,31 GB ROOT
3 SDA2 Extended 229,16 GB
SDA5 9,13 GB SWAP
spazio non allocato 1MB
SDA6 220,03 GB HOME

devo aver fatto un po di casino quando installai il disco è un SSD da 256GB

ora vado benissimo ma il problema è che le ROOT è zeppa!
mi sono letto alcuni post ma ho una grande confusione. Ho provato con GPARTED a fare dei test senza applicare i cambiamenti ma non riesco ad aumentare lo spazio del ROOT che vorrei portare a circa 30GB e poi vorrei eliminare la SWAP e fare come consigliato su altro post qui sul forum usando il file swap.

datemi qualche dritta e cosa utilizzare
grazie anticipato
Categorie: Forum Debianizzati

Re: Driver nvidia

Forum Debianizzati - Dom, 05/11/2017 - 18:59
Il log è stato fatto prima di creare il file /etc/modprobe.d/nvidia-installer-disable-nouveau.conf, va bene ugualmente?
Categorie: Forum Debianizzati

Re: Driver nvidia

Forum Debianizzati - Dom, 05/11/2017 - 18:52
Il file /etc/modprobe.d/nvidia-installer-disable-nouveau.conf non era presente e l'ho creato con le stringhe riportate.
di seguito l'output del comando groups
silvio@localhost:~$ groups
silvio cdrom floppy sudo audio dip video plugdev netdev bluetooth lpadmin scanner bumblebee
Categorie: Forum Debianizzati

Re: Driver nvidia

Forum Debianizzati - Dom, 05/11/2017 - 18:38
Eccolo
Categorie: Forum Debianizzati

Re: Driver nvidia

Forum Debianizzati - Dom, 05/11/2017 - 18:27
Verifica, per cortesia, se nel tuo sistema è presente il file /etc/modprobe.d/nvidia-installer-disable-nouveau.conf con questo contenuto:
# generated by nvidia-installer
blacklist nouveau
options nouveau modeset=0


Se possibile, fornisci l'output del seguente comando attraverso l'utente con cui avvi optirun:
groups


Infine, fornisci un nuovo log usando lo script http://guide.debianizzati.org/index.php ... i_al_forum
Categorie: Forum Debianizzati

Re: Driver nvidia

Forum Debianizzati - Dom, 05/11/2017 - 18:08
Ho fatto tutto quello che hai scritto ma il risultato purtroppo non è cambiato

silvio@localhost:~$ optirun virtualbox
[   99.485138] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) [drm] Failed to open DRM device for pci:0000:01:00.0: -19

[   99.485217] [WARN]The Bumblebee server was not available.
Categorie: Forum Debianizzati

Re: Driver nvidia

Forum Debianizzati - Dom, 05/11/2017 - 17:38
(continua dalla precedente) Inoltre, sempre dal secondo log, risulta che il server X sarebbe configurato per usare il driver nouveau attraverso il file /etc/X11/xorg.conf.d/xorg.conf (che, probabilmente, andrebbe a questo punto cancellato):
******************************************
/etc/X11/xorg.conf.d/xorg.conf
******************************************
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   Screen      1  "Screen1" RightOf "Screen0"
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
[..]
EndSection

Section "Module"
   Load  "glx"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/input/mice"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Monitor"
   Identifier   "Monitor1"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Device"
   Identifier  "Card0"
   Driver      "intel"
   BusID       "PCI:0:2:0"
EndSection

Section "Device"
   Identifier  "Card1"
   Driver      "nouveau"
   BusID       "PCI:1:0:0"
EndSection

[.. omissis..]

EndSection
Categorie: Forum Debianizzati

Samsung S5 e Debian 9

Forum Debianizzati - Dom, 05/11/2017 - 17:16
Salve a tutti. L'altro giorno, dopo essere passato a Debian 9 ho collegato il cell via usb e sono riuscito a gestire i miei file. Non ci avrei mai sperato.
Ma oggi non c'è verso di farlo funzionare! Ottengo l'errore
[  576.140001] cdc_acm 2-5:1.1: ttyACM0: USB ACM device
[  576.140467] usb 2-5: usbfs: process 1614 (ThreadWeaver::T) did not claim interface 0 before use
[  576.146608] usb 2-5: usbfs: process 1609 (ThreadWeaver::T) did not claim interface 0 before use
[  576.277963] usb 2-5: reset high-speed USB device number 4 using ehci-pci

che accade a tantissime persone.
Tentate varie vie per sistemare ma nessuna ha funzionato.

Mi sapete dare un consiglio?

Saluti.
Categorie: Forum Debianizzati
Condividi contenuti