Forum Debianizzati

Re: Video e fluidità Xfce

Forum Debianizzati - Dom, 22/04/2018 - 19:47
SolarHate ha scritto:Permane la visualizzazione dei caratteri : sono sfocati e quindi non molto definiti. [..] Anche la luce è meno " naturale " , piuttosto fredda. Ma sono due notebook diversi, quindi potrebbe essere una questione di peculiarità del monitor. Ho provato qualche modifica in in " Aspetto- Caratteri " , ma non cambia.
Se per "luce" intendi la "luminosità", l'intensità della retroilluminazione del pannello dovrebbe essere regolabile tramite combinazioni di tastiera. Prova ad inviarci una foto per farci capire cosa intendi per "caratteri sfuocati". Il log del server X è troncato e, quindi, non posso visualizzare a che risoluzione e con che frequenza sta operando il monitor; puoi provare a modificare la risoluzione o le frequenze di aggiornamento dello schermo, se possibile, da qualche programma di utilità.
Categorie: Forum Debianizzati

Re: Video e fluidità Xfce

Forum Debianizzati - Dom, 22/04/2018 - 18:02
Ho installato i pacchetti : su you tube, la situazione sembra migliorata, i video si vedono come si dovrebbero. La fluidità è migliorata leggermente in generale. Tearing sul desktop o in applicazioni aperte ormai non ne vedo, a parte durante il trascinamento delle finestre, le quali si deformano un pò ma non c'è assolutamente tearing.

Permane la visualizzazione dei caratteri : sono sfocati e quindi non molto definiti. In confronto ad altro portatile che ho ( con windows però ), mi affatico di più alla lettura. Anche la luce è meno " naturale " , piuttosto fredda. Ma sono due notebook diversi, quindi potrebbe essere una questione di peculiarità del monitor. Ho provato qualche modifica in in " Aspetto- Caratteri " , ma non cambia. Ho dato un occhio al log, ho capito solo che mancano dei firmware del modulo wifi, ma su quello ho letto che è normale così non essendoci tutti i firmware necessari disponibili da scaricare.

ps ho allegato il log aggiornato
Categorie: Forum Debianizzati

Re: Pasticcio con i repository

Forum Debianizzati - Dom, 22/04/2018 - 16:26
Per effettuare manualmente gli aggiornamenti puoi impartire in seguente comando come utente root:
script log.txt
apt-get update
apt-get upgrade
exit

Nel file log.txt troverai i comandi impartiti con il relativo output.
Categorie: Forum Debianizzati

Re: Video e fluidità Xfce

Forum Debianizzati - Dom, 22/04/2018 - 16:06
Dal log che hai inviato risulta:
apr 22 14:37:06 debian kernel: i915 0000:00:02.0: firmware: failed to load i915/kbl_dmc_ver1_01.bin (-2)
apr 22 14:37:06 debian kernel: i915 0000:00:02.0: Direct firmware load for i915/kbl_dmc_ver1_01.bin failed with error -2
apr 22 14:37:06 debian kernel: i915 0000:00:02.0: Failed to load DMC firmware [https://01.org/linuxgraphics/intel-linux-graphics-firmwares]

Questo messaggio indica che non hai installato il firmware per la scheda grafica intel; per farlo, puoi installare il seguente pacchetto: firmware-misc-nonfree. Questo potrebbe spiegare la estrema lentezza che riferisci nella resa grafica.

A latere, segnalo che sono presenti messaggi di errore relativi anche ad altro firmware:
apr 22 14:37:07 debian kernel: r8169 0000:02:00.0: firmware: failed to load rtl_nic/rtl8106e-1.fw (-2)
apr 22 14:37:07 debian kernel: r8169 0000:02:00.0: Direct firmware load for rtl_nic/rtl8106e-1.fw failed with error -2
apr 22 14:37:07 debian kernel: r8169 0000:02:00.0 enp2s0: unable to load firmware patch rtl_nic/rtl8106e-1.fw (-2)

Per installare questo firmware, puoi installare il pacchetto firmware-realtek

Dopo aver fatto questo potrebbe essere utile, dopo il riavvio, generare un nuovo log per verificare se le azioni correttive sono andate a buon fine.
Categorie: Forum Debianizzati

Re: Video e fluidità Xfce

Forum Debianizzati - Dom, 22/04/2018 - 15:21
Ciao Aki, ho allegato il log compresso..
Categorie: Forum Debianizzati

Re: Pasticcio con i repository

Forum Debianizzati - Dom, 22/04/2018 - 14:50
come faccio a constatarlo? posso lanciare io un comando per aggiornare oppure scegliere se farlo in automatico o no?
Categorie: Forum Debianizzati

Re: [RISOLTO] usb 2-5: device descriptor read/64, error -110

Forum Debianizzati - Dom, 22/04/2018 - 11:50
Felice di esserti stato utile. Happy Debian & Happy Hacking.
Categorie: Forum Debianizzati

Re: usb 2-5: device descriptor read/64, error -110

Forum Debianizzati - Dom, 22/04/2018 - 11:29
Grazie mille! Il bluetooth non lo uso mai, ho messo il modulo (ath3k) in blacklist come consigliato e l'errore non si presenta più!
Categorie: Forum Debianizzati

Re: usb 2-5: device descriptor read/64, error -110

Forum Debianizzati - Dom, 22/04/2018 - 08:35
Facendo una rapida ricerca, si trovano molte segnalazioni in merito all’errore specificamente collegato al chip bluetooth utilizzato dal tuo computer. Alcuni riferiscono che l’errore si verifichi prevalentemente nelle fasi di avvio iniziali del sistema operativo e che, quindi, non caricando in queste fasi il modulo del kernel, ma facendolo nelle fasi tardive, si possa evitare la comparsa dell’errore ed avere anche il bluetooth funzionante. Una soluzione, ad esempio, è spiegata qui : https://forums.linuxmint.com/viewtopic.php?t=185387 . Se al momento non usi le funzionalità bluetooth del computer puoi semplicemente metterne il modulo del kernel in blacklist in modo che il bluetooth non sia attivato.
Categorie: Forum Debianizzati

Re: usb 2-5: device descriptor read/64, error -110

Forum Debianizzati - Dom, 22/04/2018 - 08:35
Facendo una rapida ricerca, si trovano molte segnalazioni in merito all’errore specificamente collegato al chip bluetooth utilizzato dal tuo computer. Alcuni riferiscono che l’errore si verifichi prevalentemente nelle fasi di avvio iniziali del sistema operativo e che, quindi, non caricando in queste fasi il modulo del kernel, ma facendolo nelle fasi tardive, si possa evitare la comparsa dell’errore ed avere anche il bluetooth funzionante. Una soluzione, ad esempio, è spiegata qui : https://forums.linuxmint.com/viewtopic.php?t=185387 . Se al momento non usi le funzionalità bluetooth del computer puoi semplicemente metterne il modulo del kernel in blacklist in modo che il bluetooth non sia attivato.
Categorie: Forum Debianizzati

Re: usb 2-5: device descriptor read/64, error -110

Forum Debianizzati - Sab, 21/04/2018 - 14:59
No, come dovrei cercare per individuare questo tipo di errori? Per il bluetooth installai firmware-atheros mi pare. Comunque "greppando" syslog ho trovato questo:
~$ sudo grep -i "usb 2-5" /var/log/syslog
Apr 21 13:38:17 mpc kernel: [    1.401074] usb 2-5: new full-speed USB device number 2 using xhci_hcd
Apr 21 13:38:17 mpc kernel: [    1.542111] usb 2-5: New USB device found, idVendor=04ca, idProduct=300b
Apr 21 13:38:17 mpc kernel: [    1.542114] usb 2-5: New USB device strings: Mfr=0, Product=0, SerialNumber=0
Apr 21 13:38:17 mpc kernel: [    2.135004] usb 2-5: firmware: direct-loading firmware ar3k/ramps_0x31010000_40.dfu
Apr 21 13:38:17 mpc kernel: [    2.139653] usb 2-5: USB disconnect, device number 2
Apr 21 13:38:17 mpc kernel: [    2.441059] usb 2-5: new full-speed USB device number 4 using xhci_hcd
Apr 21 13:38:21 mpc kernel: [    7.789509] usb 2-5: device descriptor read/64, error -110
Apr 21 13:38:26 mpc kernel: [   13.190723] usb 2-5: New USB device found, idVendor=04ca, idProduct=300b
Apr 21 13:38:26 mpc kernel: [   13.190726] usb 2-5: New USB device strings: Mfr=0, Product=0, SerialNumber=0
~$ sudo grep -i "bluetooth" /var/log/syslog
Apr 21 13:38:17 mpc kernel: [    2.104866] Bluetooth: Core ver 2.22
Apr 21 13:38:17 mpc kernel: [    2.104897] Bluetooth: HCI device and connection manager initialized
Apr 21 13:38:17 mpc kernel: [    2.104902] Bluetooth: HCI socket layer initialized
Apr 21 13:38:17 mpc kernel: [    2.104905] Bluetooth: L2CAP socket layer initialized
Apr 21 13:38:17 mpc kernel: [    2.104911] Bluetooth: SCO socket layer initialized
Apr 21 13:38:26 mpc systemd[1]: Reached target Bluetooth.
~$ sudo grep -i "missing" /var/log/syslog
~$ sudo grep -i "firmware" /var/log/syslog
Apr 21 13:38:17 mpc kernel: [    0.185582] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
Apr 21 13:38:17 mpc kernel: [    2.135004] usb 2-5: firmware: direct-loading firmware ar3k/ramps_0x31010000_40.dfu
Apr 21 13:38:17 mpc kernel: [    2.193466] [Firmware Bug]: ACPI(PEGP) defines _DOD but not _DOS
Apr 21 13:38:23 mpc kernel: [   10.057773] r8169 0000:01:00.1: firmware: direct-loading firmware rtl_nic/rtl8411-2.fw
~$
Categorie: Forum Debianizzati

Re: usb 2-5: device descriptor read/64, error -110

Forum Debianizzati - Sab, 21/04/2018 - 14:59
No, come dovrei cercare per individuare questo tipo di errori? Per il bluetooth installai firmware-atheros mi pare. Comunque "greppando" syslog ho trovato questo:
~$ sudo grep -i "usb 2-5" /var/log/syslog
Apr 21 13:38:17 mpc kernel: [    1.401074] usb 2-5: new full-speed USB device number 2 using xhci_hcd
Apr 21 13:38:17 mpc kernel: [    1.542111] usb 2-5: New USB device found, idVendor=04ca, idProduct=300b
Apr 21 13:38:17 mpc kernel: [    1.542114] usb 2-5: New USB device strings: Mfr=0, Product=0, SerialNumber=0
Apr 21 13:38:17 mpc kernel: [    2.135004] usb 2-5: firmware: direct-loading firmware ar3k/ramps_0x31010000_40.dfu
Apr 21 13:38:17 mpc kernel: [    2.139653] usb 2-5: USB disconnect, device number 2
Apr 21 13:38:17 mpc kernel: [    2.441059] usb 2-5: new full-speed USB device number 4 using xhci_hcd
Apr 21 13:38:21 mpc kernel: [    7.789509] usb 2-5: device descriptor read/64, error -110
Apr 21 13:38:26 mpc kernel: [   13.190723] usb 2-5: New USB device found, idVendor=04ca, idProduct=300b
Apr 21 13:38:26 mpc kernel: [   13.190726] usb 2-5: New USB device strings: Mfr=0, Product=0, SerialNumber=0
~$ sudo grep -i "bluetooth" /var/log/syslog
Apr 21 13:38:17 mpc kernel: [    2.104866] Bluetooth: Core ver 2.22
Apr 21 13:38:17 mpc kernel: [    2.104897] Bluetooth: HCI device and connection manager initialized
Apr 21 13:38:17 mpc kernel: [    2.104902] Bluetooth: HCI socket layer initialized
Apr 21 13:38:17 mpc kernel: [    2.104905] Bluetooth: L2CAP socket layer initialized
Apr 21 13:38:17 mpc kernel: [    2.104911] Bluetooth: SCO socket layer initialized
Apr 21 13:38:26 mpc systemd[1]: Reached target Bluetooth.
~$ sudo grep -i "missing" /var/log/syslog
~$ sudo grep -i "firmware" /var/log/syslog
Apr 21 13:38:17 mpc kernel: [    0.185582] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
Apr 21 13:38:17 mpc kernel: [    2.135004] usb 2-5: firmware: direct-loading firmware ar3k/ramps_0x31010000_40.dfu
Apr 21 13:38:17 mpc kernel: [    2.193466] [Firmware Bug]: ACPI(PEGP) defines _DOD but not _DOS
Apr 21 13:38:23 mpc kernel: [   10.057773] r8169 0000:01:00.1: firmware: direct-loading firmware rtl_nic/rtl8411-2.fw
~$
Categorie: Forum Debianizzati

Re: usb 2-5: device descriptor read/64, error -110

Forum Debianizzati - Sab, 21/04/2018 - 14:29
Hai verificato se nei log sono presenti errori rispetto alla mancanza di firmware, ad esempio per la scheda Bluetooth ?
Categorie: Forum Debianizzati

Re: usb 2-5: device descriptor read/64, error -110

Forum Debianizzati - Sab, 21/04/2018 - 14:29
Hai verificato se nei log sono presenti errori rispetto alla mancanza di firmware, ad esempio per la scheda Bluetooth ?
Categorie: Forum Debianizzati

Video e fluidità Xfce

Forum Debianizzati - Sab, 21/04/2018 - 13:53
Ciao a tutti! Ho installato Debian con Xfce. Mi sto scervellando per trovare un modo di eliminare il tearing , aumentare la fluidità dello scrolling e migliorare la qualità dei vide online e su vlc :

Ho creato il file 20-intel.conf non in /etc/X11/xorg.conf.d ( non esiste la cartella) , ma in /usr/share/X11/xorg.conf.d/. abilitando " tearing : "true" " Il tearing è diminuito. Non contento, ho disattivato il compositore e installato Compton, scritto il file " compton.conf"con dentro vari parmetri di prova, ma non è quella la strada a quanto pare.
In seguito ho provato a disinstallare xserver-xorg-video-intel, ma al riavvio ho dovuto reinstallare perchè probabilmente si era portato con se qualche dipendenza, e l'interfaccia grafica era sparita.

Il desktop risulta ancora non particolarmente fluido, persiste un leggero tearing e quando scrollo specialmente su Firefox, noto che non è come dovrebbe essere, con quel fastidioso sfarfallio. Anche i caratteri non vanno, hanno una leggera sfocatura. Tra l'altro i video ad esempio su You Tube, non si vedono in HD. La spunta è su 720p ad esempio, ma la qualità non è quella comparando con altri so.
Ho tentato di aprire un video tramite flusso rete su Vlc, ma il risultato è catastrofico, le immagini sono fortemente distorte e si vede quasi tutto nero. In giro ne ho lette di ogni, sinceramente non saprei che fare per ora, voi avete qualche consiglio da darmi? Vi lascio qualche info :

20-intel-con così compilato :
Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "TearFree"    "true"



root@debian:/home/zkud# lshw -c display
  *-display                 
       description: VGA compatible controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 02
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:281 memory:d0000000-d0ffffff memory:c0000000-cfffffff ioport:f000(size=64) memory:c0000-dffff


I driver in uso dovvrebbero esssere quelli giusti.



root@debian:/home/zkud# glxinfo | grep render
direct rendering: Yes
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 620 (Kabylake GT2)
    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth,
    GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_packed_depth_stencil,
    GL_ARB_compute_shader, GL_ARB_conditional_render_inverted,
    GL_MESA_window_pos, GL_NV_blend_square, GL_NV_conditional_render,
    GL_OES_element_index_uint, GL_OES_fbo_render_mipmap,
Categorie: Forum Debianizzati

[RISOLTO] usb 2-5: device descriptor read/64, error -110

Forum Debianizzati - Sab, 21/04/2018 - 13:46
Salve a tutti, da un po' di tempo, 9 volte su 10, ottengo questo errore
usb 2-5: device descriptor read/64, error -110
all'avvio del pc (laptop acer con i3-4030U, 8gb ram, Debian 9.4).
Non noto nulla di strano, il sistema funziona bene così come le porte usb, solo questa scritta al boot che è un po' fastidiosa dato che non utilizzo un display manager, faccio il login da tty e mentre sono li a scrivere l'username, l'errore viene viene stampato nella schermata di login incasinandomi l'input.
Sapete a cosa è dovuto e come protrei eventualmente fixarlo?
~$ lsusb
Bus 001 Device 002: ID 8087:8000 Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 004: ID 04f2:b469 Chicony Electronics Co., Ltd
Bus 002 Device 005: ID 04ca:300b Lite-On Technology Corp. Atheros AR3012 Bluetooth
Bus 002 Device 002: ID 046d:c52e Logitech, Inc. MK260 Wireless Combo Receiver
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
~$ lspci | grep -i usb
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:1d.0 USB controller: Intel Corporation 8 Series USB EHCI #1 (rev 04)
~$
Categorie: Forum Debianizzati

usb 2-5: device descriptor read/64, error -110

Forum Debianizzati - Sab, 21/04/2018 - 13:46
Salve a tutti, da un po' di tempo, 9 volte su 10, ottengo questo errore
usb 2-5: device descriptor read/64, error -110
all'avvio del pc (laptop acer con i3-4030U, 8gb ram, Debian 9.4).
Non noto nulla di strano, il sistema funziona bene così come le porte usb, solo questa scritta al boot che è un po' fastidiosa dato che non utilizzo un display manager, faccio il login da tty e mentre sono li a scrivere l'username, l'errore viene viene stampato nella schermata di login incasinandomi l'input.
Sapete a cosa è dovuto e come protrei eventualmente fixarlo?
~$ lsusb
Bus 001 Device 002: ID 8087:8000 Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 004: ID 04f2:b469 Chicony Electronics Co., Ltd
Bus 002 Device 005: ID 04ca:300b Lite-On Technology Corp. Atheros AR3012 Bluetooth
Bus 002 Device 002: ID 046d:c52e Logitech, Inc. MK260 Wireless Combo Receiver
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
~$ lspci | grep -i usb
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:1d.0 USB controller: Intel Corporation 8 Series USB EHCI #1 (rev 04)
~$
Categorie: Forum Debianizzati
Condividi contenuti